This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 191912 - Marvell 88E8055 Gigabit Ethernet adapter does not work
Marvell 88E8055 Gigabit Ethernet adapter does not work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
high Severity high
: ---
: ---
Assigned To: John W. Linville
Brian Brock
: FutureFeature, Reopened
Depends On:
Blocks: 196464 198694 200231
  Show dependency treegraph
 
Reported: 2006-05-16 09:20 EDT by Rainer Koenig
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2007-0304
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 21:29:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rainer Koenig 2006-05-16 09:20:09 EDT
Description of problem:


Version-Release number of selected component (if applicable):
2.6.9-34EL

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL4 on FSC CELSIUS H240 Workstation
2. Boot 
3. Try to config the eth0 interface with DHCP or static adresses
  
Actual results:
The eth0 interface is not working at all.

Expected results:
DHCP assigns an IP and the eth0 is working fine.

Additional info:
The module used is "sky2". The card works fine if I install either
- Fedora Core 5 
- Kernel 2.6.16.9 

It does also not work with the latest RHEL4 U4 test kernel 2.6.9-36EL. 

The module version of the affected kernels is: 1.1 (I assume 0.11 is more
correct in this case :-)

The module version 0.15 from the latest vanilla kernel works, so I guess that
some of the patches between those 2 versions need to be applied to the RHEL kernel.
Comment 1 John W. Linville 2006-05-17 09:52:58 EDT
Actually, 0.15 is a couple of months old.  The sky2 driver is currently under 
very active development. 
 
Test kernels w/ patches to update sky2 to version 1.3 are available here: 
 
   http://people.redhat.com/linville/kernels/rhel4/ 
 
Please give those a try and post the results here...thanks! 
Comment 3 Rainer Koenig 2006-05-18 01:59:59 EDT
Hi John,

this morning I tried kernel-smp-2.6.9-36.EL.jwltest.137.i686.rpm and it seems to
solve the problem. I did a NETWORK2 test from the RHR2 test suite and it passed.

Yesterday afternoon I had some other funny experience with the latest "official"
U4 test kernel (2.6.9-36.ELsmp). I tried if the card works with the sk98lin
module, but it doesn't. The interesting part was that when I have the sk98lin
module loaded and then bring up the network interface with the sky2 module...
the network comes up. The price you have to pay for this "workaround" is that
the combination of the 2 modules obviously cause a thing that one of my
colleauges called "IRQ storm". The visual effect of such a storm is that when
you type in a xterm the keystrokes appear with a delay of 1..5 seconds. So this
is definitely not a solution. :-)

Anyway, your own test kernel works fine and passes the RHR test. 

Thanks a lot for your contribution
Rainer
Comment 14 RHEL Product and Program Management 2006-08-16 16:20:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this enhancement by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This enhancement is not yet committed for inclusion in an Update
release.
Comment 19 Jason Baron 2006-10-16 11:58:13 EDT
committed in stream U5 build 42.19. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 22 Mike Gahagan 2007-04-11 14:12:52 EDT
It looks like the sky2 driver is at version 1.6 in the -54 kernel. Does anyone
know if we have any of these cards in RDU that I can try out? Otherwise we will
just have to go with partner/customer testing done to date.
Comment 23 John W. Linville 2007-04-12 09:25:11 EDT
I am unable to locate one in my stash.  Perhaps Andy or Neil has one?
Comment 24 Neil Horman 2007-04-12 09:44:51 EDT
sorry, none in my pile.
Comment 25 Andy Gospodarek 2007-04-12 10:13:55 EDT
I don't have any either.   /me wonders if we should buy some....

At one point I thought Larry was going to get them to send us some laptops for
testing/cert.  What happened to that?
Comment 27 Red Hat Bugzilla 2007-05-07 21:29:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html

Note You need to log in before you can comment on or make changes to this bug.