Bug 191933 - Oops with RAID0
Summary: Oops with RAID0
Status: CLOSED DUPLICATE of bug 198495
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Doug Ledford
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 176344
TreeView+ depends on / blocked
 
Reported: 2006-05-16 15:06 UTC by Joshua Baker-LePain
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 18:20:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial console capture of Oops (2.66 KB, application/octet-stream)
2006-05-16 15:06 UTC, Joshua Baker-LePain
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0304 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 5 2007-04-28 18:58:50 UTC

Description Joshua Baker-LePain 2006-05-16 15:06:41 UTC
Description of problem:
I have a system with 2 3ware 9550SX-12 boards, each running 11 disk hardware
RAID 5s.  I want to do a stripe across these 2 large (>2TiB) disks.  I
can create the array just fine, but the system Oopses every time I try
to mke2fs the array.  Running mke2fs on 1 of the "disks" works just fine.

Version-Release number of selected component (if applicable):
2.6.9-34.ELsmp

How reproducible:
Every time

Steps to Reproduce:
1. mdadm -C /dev/md0 -l 0 -c 512 -n 2 /dev/sd[bc]1
2. mke2fs -b 4096 -j -m 0 -E stride=128 -O dir_index -T largefile4 /dev/md0
3. 
  
Actual results:
Oops (see attached serial console capture)

Expected results:
It should chug right along.

Additional info:
I asked on the linux-raid list, and Neil Brown pointed me at this patch
<http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdif
f;h=1eb29128c644581fa51f822545921394ad4f719f>.  I created a custom kernel from
the SRPM with this patch, and the problem seems to be resolved.

Comment 1 Joshua Baker-LePain 2006-05-16 15:06:42 UTC
Created attachment 129202 [details]
serial console capture of Oops

Comment 3 Doug Ledford 2006-09-18 22:25:52 UTC
I've posted the patch internally for review/possible inclusion in the next RHEL
update.  Thanks for the consice report and pretested fix.

Comment 6 Joshua Baker-LePain 2006-09-19 19:24:29 UTC
No problem.  Thank *you* for reminding me that this fix isn't in u4.  I was
about to update that server.  :)

Comment 9 Doug Ledford 2006-09-22 18:20:35 UTC

*** This bug has been marked as a duplicate of 198495 ***


Note You need to log in before you can comment on or make changes to this bug.