Bug 1919405 - uncaught exception after a celery worker process abruptly terminates, resulting in a hung task
Summary: uncaught exception after a celery worker process abruptly terminates, resulti...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Pulp
Version: 6.7.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: 6.8.4
Assignee: satellite6-bugs
QA Contact: Lai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-22 19:55 UTC by James Jeffers
Modified: 2023-12-15 20:10 UTC (History)
18 users (show)

Fixed In Version: pulp-2.21.3.3-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1889795
Environment:
Last Closed: 2021-02-24 12:47:13 UTC
Target Upstream Version:
Embargoed:
jjeffers: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 5502 0 Normal CLOSED - CURRENTRELEASE worker fails to mark a task as failed when critical conditions are encountered 2021-05-17 10:12:17 UTC
Pulp Redmine 8251 0 Normal MODIFIED Traceback in 2.21.5 when logging during task.on_failure() 2021-02-12 17:19:17 UTC
Red Hat Knowledge Base (Solution) 5569881 0 None None None 2021-01-22 19:55:39 UTC
Red Hat Product Errata RHBA-2021:0654 0 None None None 2021-02-24 12:47:36 UTC

Comment 9 pulp-infra@redhat.com 2021-02-12 14:06:00 UTC
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.

Comment 10 pulp-infra@redhat.com 2021-02-12 14:06:01 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 11 pulp-infra@redhat.com 2021-02-12 17:19:18 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 17 Lai 2021-02-22 16:39:49 UTC
Steps to test:

Steps to Reproduce:
1. Invoke some bigger CV publish/promote (with more repos inside)
2. While there are pulp celery workers processing the sync/publish tasks, kill some of them via "kill -SIGHUP <pid>"
3. Check /var/log/messages
4. Verify in the web UI that the foreman task errors out
5. Verify that the task can be resumed and completes successfully

Expected result:
3. log should not show error message or traceback
4. Foreman task should show task error out
5. Task should complete successfull

Actual Result:
3. Log still shows traceback
4. Action:
Actions::Pulp::Repository::CopyAllUnits

{"pulp_tasks"=>
.......................
  "queue"=>
     "reserved_resource_worker-5@<hostname>",
    "state"=>"error",
    "worker_name"=>
     "reserved_resource_worker-5@<hostname>",
    "result"=>nil,
    "error"=>
     {"code"=>"PLP0049",
      "data"=>{"task_id"=>"c2fffb9a-67c4-4238-8fb2-61bf692c40b9"},
      "description"=>
       "Worker terminated abnormally while processing task c2fffb9a-67c4-4238-8fb2-61bf692c40b9.  Check the logs for details",
      "sub_errors"=>[]},
    "_id"=>{"$oid"=>"6033cbf0dbf4aca8772c8791"},
    "id"=>"6033cbf0dbf4aca8772c8791"},
.........................................
5.  Task completes successfully

Name:Publish content view 'some'; organization 'Default Organization'
Start at:1 hour ago
Result: success
Started at:1 hour ago
Triggered by:admin
Ended at:56 minutes ago
Execution type:Immediate
Start before:-

Though there is still a traceback in the log, this does not affect how the fix to the problem was applied.  The task error out and does not hang anymore and users can resume the task without issues.

Verified on 6.8.4_02 with pulp-rpm-plugins-2.21.3.3-1.el7sat.noarch

Comment 22 errata-xmlrpc 2021-02-24 12:47:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Satellite 6.8.4 Async Bug Fix Update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0654

Comment 23 pulp-infra@redhat.com 2021-05-17 10:12:14 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 24 pulp-infra@redhat.com 2021-05-17 10:12:18 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.


Note You need to log in before you can comment on or make changes to this bug.