Bug 1919453 - OpenShift test suites are not resilient to rate limited registries (like docker.io) and cannot control their dependencies for offline use
Summary: OpenShift test suites are not resilient to rate limited registries (like dock...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Test Infrastructure
Version: 4.6.z
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.z
Assignee: Clayton Coleman
QA Contact: Bruno Andrade
URL:
Whiteboard:
: 1920013 1940390 (view as bug list)
Depends On: 1816812
Blocks: 1920013
TreeView+ depends on / blocked
 
Reported: 2021-01-22 21:55 UTC by OpenShift BugZilla Robot
Modified: 2022-01-27 08:31 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1920013 (view as bug list)
Environment:
job=periodic-ci-openshift-release-master-nightly-4.6-e2e-vsphere=all job=periodic-ci-openshift-release-master-nightly-4.6-e2e-vsphere-upi=all
Last Closed: 2022-01-27 08:30:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 26729 0 None open [release-4.6] Bug 1919453: configure tests to pull images from mirror 2022-01-06 14:09:13 UTC
Red Hat Product Errata RHBA-2022:0180 0 None None None 2022-01-27 08:31:04 UTC

Comment 1 Clayton Coleman 2021-01-25 14:53:18 UTC
*** Bug 1920013 has been marked as a duplicate of this bug. ***

Comment 2 Clayton Coleman 2021-01-25 14:53:37 UTC
Backporting from 1919453 so that 4.6.z is resilient to rate limited registries for its entire lifecycle as an EUS.

Will involve changes to ose-tests to be brought into line with 4.7.

Comment 5 Bruno Andrade 2021-02-18 14:07:48 UTC
https://github.com/openshift/origin/pull/24887 must be cherry-picked to release-4.6, moving to assigned.


1, Compile the `openshift-tests` binary from the master branch. Check this new sub-command `images` help info.
go/src/github.com/openshift/origin ‹release-4.6› 
╰─$ make build
go build -mod=vendor -trimpath -ldflags "-s -w -X github.com/openshift/origin/pkg/version.versionFromGit="v4.1.0-3277-g0eda899" -X github.com/openshift/origin/pkg/version.commitFromGit="0eda8999bf" -X github.com/openshift/origin/pkg/version.gitTreeState="clean" -X github.com/openshift/origin/pkg/version.buildDate="2021-02-17T15:50:01Z" " github.com/openshift/origin/cmd/openshift-tests


~/go/src/github.com/openshift/origin ‹release-4.6› 
╰─$ ls -l openshift-tests 
  rwxrwxr-x  1  bandrade  bandrade   148 MiB  Wed Feb 17 13:00:35 2021    openshift-tests 

 ./openshift-tests images --help 
Error: unknown command "images" for ""
Run ' --help' for usage.
error: unknown command "images" for ""

Comment 7 Oleg Bulatov 2021-07-25 12:21:35 UTC
*** Bug 1940390 has been marked as a duplicate of this bug. ***

Comment 13 Bruno Andrade 2022-01-07 17:32:22 UTC
Marking as VERIFIED

1a58eae942 - (HEAD -> release-4.6, origin/release-4.6) Merge pull request #26729 from rvanderp3/patch-docker-io-references (20 hours ago) <OpenShift Merge Robot>

export TEST_IMAGE_MIRROR_REGISTRY=quay.io/bandrade/e2e 
podman run -d -p 5000:5000 -v /home/admin/registry_storage:/var/lib/registry:Z -v /home/admin/registry_certs:/certs:Z --restart always --name registry-docker.io -e REGISTRY_HTTP_ADDR=0.0.0.0:5000 -e REGISTRY_HTTP_TLS_CERTIFICATE=/certs/domain.crt -e REGISTRY_HTTP_TLS_KEY=/certs/domain.key -e REGISTRY_PROXY_REMOTEURL="https://registry-1.docker.io" registry:2 
Resolved "registry" as an alias (/etc/containers/registries.conf.d/000-shortnames.conf)
Trying to pull docker.io/library/registry:2...
Getting image source signatures
Copying blob 79e9f2f55bf5 done  
Copying blob 5b27040df4a2 done  
Copying blob e2ead8259a04 done  
Copying blob 0d96da54f60b done  
Copying blob 3790aef225b9 done  
Copying config b8604a3fe8 done  

Run the tests over an disconnected environment:

./openshift-tests run  openshift/test-cmd                                                                                                             

openshift-tests version: v4.1.0-3337-g1a58eae
I0107 14:31:30.374312   83712 test_context.go:429] Tolerating taints "node-role.kubernetes.io/master" when considering if nodes are ready
started: (0/1/42) "[sig-cli][Feature:LegacyCommandTests][Disruptive][Serial] test-cmd: test/cmd/volumes.sh"

Comment 17 errata-xmlrpc 2022-01-27 08:30:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.54 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0180


Note You need to log in before you can comment on or make changes to this bug.