Bug 191948 - gdb segfaults on ia64
Summary: gdb segfaults on ia64
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb   
(Show other bugs)
Version: rawhide
Hardware: ia64
OS: Linux
Target Milestone: ---
Assignee: Alexandre Oliva
QA Contact:
Depends On:
Blocks: fedora-ia64
TreeView+ depends on / blocked
Reported: 2006-05-16 15:45 UTC by Doug Chapman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: gdb-
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-19 12:28:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
stack trace of gdb segvault (4.19 KB, text/plain)
2006-05-16 18:23 UTC, Doug Chapman
no flags Details

Description Doug Chapman 2006-05-16 15:45:53 UTC
Description of problem:
gdb on rawhide ia64 hits a segmentation fault when doing any debugging.  Simply
running a simple hello world program through it will hit this.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. compile a hello world with -g
2. gdb a.out
3. run
Actual results:
Segmentation fault

Expected results:

Additional info:

Comment 1 Doug Chapman 2006-05-16 15:49:45 UTC
A little more info...

I also tried compiling with -static with the same results.  Also tried compiling
both normal and static on a RHEL4 system and running on rawhide with the same

Comment 2 Tony Luck 2006-05-16 16:08:29 UTC
Works (sort of) (on a slightly older?) RHEL4 installation.

$ gdb --version
GNU gdb Red Hat Linux (

$ rpm -q -f /usr/bin/gdb

I do see a "Failed to read a valid object file image from memory." on startup 
of gdb, and when I type "run", but no SIGSEGV, and things otherwise seem to be 
working (can set breakpoints, gdb stops at them and prints reasonable location 
information).  This was with a kernel.org kernel.  Running with RHEL4 kernel 
2.6.9-34.EL, I see similar results ... gdb works, but there are some warning 
messages (e.g. "warning: cannot close "shared object read from target memory": 
File in wrong format").

Comment 3 Doug Chapman 2006-05-16 17:21:24 UTC
Tony's note above gave me the idea to try the RHEL4 gdb on rawhide.  I removed
gdb and installed gdb- from the RHEL4 tree.  This version
of gdb works with no problem.  I don't see the error that Tony mentions here.

Comment 4 Doug Chapman 2006-05-16 18:23:08 UTC
Created attachment 129253 [details]
stack trace of gdb segvault

This was created by setting "ulimit -c" so that gdb would create a core file
then using the RHEL4 gdb to read that core and get a stack trace.

Comment 5 Émeric Maschino 2006-05-16 19:04:29 UTC
FYI, gdb- shipped with the ia64 FC5 ISO DVD image posted by Prarit
on oss.sgi.com is running fine too.

Comment 7 Alexandre Oliva 2006-05-17 13:54:38 UTC
Thanks for the report, this should be fixed in tomorrow's rawhide,

Comment 8 Émeric Maschino 2006-05-18 23:49:51 UTC
I confirm that today's Rawhide gdb- is working again. Many
thanks for this quick fix.

Comment 9 Fedora Update System 2006-09-15 01:46:46 UTC
gdb- has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.