This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 191950 - cups does not start because another program has taken port 631
cups does not start because another program has taken port 631
Status: CLOSED DUPLICATE of bug 103401
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-16 11:46 EDT by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-16 11:50:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-05-16 11:46:16 EDT
Description of problem:

Occaisionally a portmap/RPC based program like ypbind will take port 631 before
cups starts up.  cups then aborts with the following in the log:

E [04/May/2006:10:53:04 -0600] StartListening: Unable to bind socket for address
7f000001:631 - Address already in use.

Version-Release number of selected component (if applicable):
cups-1.1.23-15.4

How reproducible:
Random


This is a known issue with portmap/bindresvport programs.  There are other bugs
about this issue, though I can't find them at the moment.  One fix is the start
cups before any portmap services, but I'm not sure this is possible.
Comment 1 Tim Waugh 2006-05-16 11:50:47 EDT

*** This bug has been marked as a duplicate of 103401 ***

Note You need to log in before you can comment on or make changes to this bug.