Bug 191960 - metacity Package won't build in mock
metacity Package won't build in mock
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-16 12:07 EDT by Andreas Thienemann
Modified: 2014-06-18 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.15.3-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 23:38:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Build Log on x86_64 (58.45 KB, text/plain)
2006-05-16 12:07 EDT, Andreas Thienemann
no flags Details

  None (edit)
Description Andreas Thienemann 2006-05-16 12:07:25 EDT
Building metacity-2.15.2-2 in mock fails:

if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/include/glib-2.0
-I/usr/lib64/glib-2.0/include       -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -MT
overlaytest.o -MD -MP -MF ".deps/overlaytest.Tpo" -c -o overlaytest.o
overlaytest.c; \
then mv -f ".deps/overlaytest.Tpo" ".deps/overlaytest.Po"; else rm -f
".deps/overlaytest.Tpo"; exit 1; fi
overlaytest.c:1:19: error: cm/ws.h: No such file or directory
overlaytest.c: In function 'main':
overlaytest.c:6: warning: implicit declaration of function 'g_type_init'
overlaytest.c:8: error: 'WsDisplay' undeclared (first use in this function)
overlaytest.c:8: error: (Each undeclared identifier is reported only once
overlaytest.c:8: error: for each function it appears in.)
overlaytest.c:8: error: 'display' undeclared (first use in this function)
overlaytest.c:8: warning: implicit declaration of function 'ws_display_new'
overlaytest.c:8: error: 'NULL' undeclared (first use in this function)
overlaytest.c:9: error: 'WsScreen' undeclared (first use in this function)
overlaytest.c:9: error: 'screen' undeclared (first use in this function)
overlaytest.c:9: warning: implicit declaration of function
'ws_display_get_default_screen'
overlaytest.c:10: error: 'WsWindow' undeclared (first use in this function)
overlaytest.c:10: error: 'root' undeclared (first use in this function)
overlaytest.c:10: warning: implicit declaration of function
'ws_screen_get_root_window'
overlaytest.c:11: error: 'overlay' undeclared (first use in this function)
overlaytest.c:13: warning: implicit declaration of function
'ws_display_init_composite'
overlaytest.c:15: warning: implicit declaration of function
'ws_window_redirect_subwindows'
overlaytest.c:17: warning: implicit declaration of function
'ws_screen_get_gl_window'
overlaytest.c:19: warning: implicit declaration of function 'g_print'
make[3]: *** [overlaytest.o] Error 1
make[3]: Leaving directory `/builddir/build/BUILD/metacity-2.15.2/libcm-0.0.19/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/builddir/build/BUILD/metacity-2.15.2/libcm-0.0.19/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/metacity-2.15.2/libcm-0.0.19'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.18916 (%build)

As ws.h is supplied by metacity, this looks like a circular dependency.
A build-log is attached.
Comment 1 Andreas Thienemann 2006-05-16 12:07:25 EDT
Created attachment 129217 [details]
Build Log on x86_64
Comment 2 Matthias Clasen 2006-05-22 14:21:12 EDT
waiting for a new libcm
Comment 3 Matt Domsch 2006-05-23 23:38:34 EDT
metacity-2.15.3-2.src.rpm builds on i386 and x86_64.

Note You need to log in before you can comment on or make changes to this bug.