Bug 1919634 - ICE with kodi on aarch64 "Error: open CFI at the end of file; missing .cfi_endproc directive"
Summary: ICE with kodi on aarch64 "Error: open CFI at the end of file; missing .cfi_en...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 33
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-24 10:11 UTC by Nicolas Chauvet (kwizart)
Modified: 2021-01-28 07:29 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-28 07:29:29 UTC
Type: Bug


Attachments (Terms of Use)
VideoInfoScanner.cpp (76.64 KB, text/x-csrc)
2021-01-24 10:24 UTC, Nicolas Chauvet (kwizart)
no flags Details

Description Nicolas Chauvet (kwizart) 2021-01-24 10:11:37 UTC
Description of problem:
There is an ICE related 

Version-Release number of selected component (if applicable):
gcc-10.2.1-9.fc33
and
gcc-11.0.0-0.16.fc34


How reproducible:
build kodi for rpmfusion-free on aarch64. Others arches (x86_64 and armv7hl) are OK

Steps to Reproduce:
1. rfpkg clone free/kodi
2. rfpkg build (on aarch64)
3.

Actual results:
FAILED: build/video/CMakeFiles/video.dir/VideoInfoScanner.cpp.o 
/usr/bin/g++ -DHAS_NEON -I. -Ilib -Ixbmc -Ixbmc/platform/linux -Ixbmc/cores/VideoPlayer -Ibuild -Ibuild/include -Ixbmc/platform/posix -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/python3.9 -I/usr/include/samba-4.0 -I/usr/include/libxml2 -I/usr/include/ffmpeg -Ibuild/cores/RetroPlayer/messages -I/usr/include/freetype2 -I/usr/include/fribidi -Ibuild/libdvd/include -I/usr/include/lzo -I/usr/include/libdrm -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1  -mbranch-protection=standard -fasynchronous-unwind-tables -fstack-clash-protection -DNDEBUG -DTARGET_POSIX -DTARGET_LINUX -D_GNU_SOURCE -DHAVE_LINUX_UDMABUF=1 -DHAVE_LINUX_DMA_HEAP=1 -DHAVE_LINUX_DMA_BUF=1 -DHAVE_MKOSTEMP=1 -DHAVE_LINUX_MEMFD=1 -DHAVE_STATX=1 -D__STDC_CONSTANT_MACROS -D_FILE_OFFSET_BITS=64 -DHAS_POSIX_NETWORK -DHAS_LINUX_NETWORK -DHAS_BUILTIN_SYNC_ADD_AND_FETCH=1 -DHAS_BUILTIN_SYNC_SUB_AND_FETCH=1 -DHAS_BUILTIN_SYNC_VAL_COMPARE_AND_SWAP=1 -DHAVE_INOTIFY=1 -DHAVE_POSIX_FADVISE=1 -DHAVE_LOCALTIME_R=1 -DHAVE_GMTIME_R=1 -DHAVE_INTTYPES_H=1 -DHAS_ALSA=1 -DHAS_AVAHI=1 -DHAS_ZEROCONF=1 -DHAVE_LIBBLURAY=1 -DHAVE_LIBBLURAY_BDJ=1 -DHAVE_LIBCEC=1 -DHAS_DBUS=1 -DHAS_ISO9660PP=1 -DHAVE_LCMS2=1 -DHAS_LIRC=1 -DHAS_WEB_SERVER=1 -DHAS_WEB_INTERFACE=1 -DHAS_FILESYSTEM_NFS=1 -DHAS_NFS_SET_TIMEOUT -DHAS_AIRPLAY=1 -DHAS_PULSEAUDIO=1 -DHAS_PYTHON=1 -DHAS_FILESYSTEM_SMB=1 -DHAVE_LIBUDEV=1 -DHAVE_LIBXSLT=1 -DHAVE_LIBVA=1 -DHAS_GLX=1 -DHAVE_LIBVDPAU=1 -DFFMPEG_VER_SHA=\"4.3\" -I/usr/include/fribidi -DSPDLOG_FMT_EXTERNAL -DSPDLOG_DEBUG_ON -DSPDLOG_NO_ATOMIC_LEVELS -DSPDLOG_ENABLE_PATTERN_PADDING -DHAS_EGL=1 -DHAVE_X11=1 -DHAVE_LIBXRANDR=1 -DHAS_GL=1 -DHAVE_WAYLAND=1 -DHAVE_GBM=1 -DHAS_GBM_BO_MAP=1 -DHAS_GBM_MODIFIERS=1 -DHAS_MYSQL=1 -DHAS_UPNP=1 -DHAS_DVD_DRIVE -DHAS_CDDA_RIPPER -DHAS_AIRTUNES=1 -DBIN_INSTALL_PATH=\"/usr/lib64/kodi\" -DINSTALL_PATH=\"/usr/share/kodi\" -std=c++14 -MD -MT build/video/CMakeFiles/video.dir/VideoInfoScanner.cpp.o -MF build/video/CMakeFiles/video.dir/VideoInfoScanner.cpp.o.d -o build/video/CMakeFiles/video.dir/VideoInfoScanner.cpp.o -c xbmc/video/VideoInfoScanner.cpp
*** WARNING *** there are active plugins, do not report this as a bug unless you can reproduce it without enabling any plugins.
Event                            | Plugins
PLUGIN_FINISH_UNIT               | annobin: Generate final annotations
PLUGIN_START_UNIT                | annobin: Generate global annotations
PLUGIN_ALL_PASSES_START          | annobin: Generate per-function annotations
PLUGIN_ALL_PASSES_END            | annobin: Register per-function end symbols
during RTL pass: final
xbmc/video/VideoInfoScanner.cpp: In member function 'VIDEO::CVideoInfoScanner::AddVideo(CFileItem*, CONTENT_TYPE const&, bool, bool, CVideoInfoTag const*, bool)':
xbmc/video/VideoInfoScanner.cpp:1415:3: internal compiler error: Segmentation fault
 1415 |   }
      |   ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
{standard input}: Assembler messages:
{standard input}: Error: open CFI at the end of file; missing .cfi_endproc directive
The bug is not reproducible, so it is likely a hardware or OS problem.

Expected results:
It should build

Additional info:
Seems related to https://bugzilla.redhat.com/show_bug.cgi?id=1917254
But this time, it specifically affects aarch64 (and also f33 with gcc-10).
Feel free to close as duplicate as relevant.

Comment 1 Nicolas Chauvet (kwizart) 2021-01-24 10:23:40 UTC
building kodi 19-rc1
f33-free: https://koji.rpmfusion.org/koji/taskinfo?taskID=457832
f34-free: https://koji.rpmfusion.org/koji/taskinfo?taskID=457817

Comment 2 Nicolas Chauvet (kwizart) 2021-01-24 10:24:21 UTC
Created attachment 1750216 [details]
VideoInfoScanner.cpp

Comment 3 Nicolas Chauvet (kwizart) 2021-01-27 20:17:32 UTC
It's possible that the issue is not reproducible on another builder. I will close the issue if the f34 build succeed. (f33 already succeeded).

Comment 4 Nicolas Chauvet (kwizart) 2021-01-28 07:29:29 UTC
Build succeeded on another builder... Closing.


Note You need to log in before you can comment on or make changes to this bug.