Bug 191967 - mesa Missing BuildRequire on makedepend
mesa Missing BuildRequire on makedepend
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
X/OpenGL Maintenance List
:
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-16 12:27 EDT by Andreas Thienemann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-17 16:27:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch, adding the missing buildreqs (299 bytes, patch)
2006-05-16 12:27 EDT, Andreas Thienemann
no flags Details | Diff

  None (edit)
Description Andreas Thienemann 2006-05-16 12:27:06 EDT
current rawhide mesa-6.5-4 fails to build in mock:

make[3]: Entering directory `/builddir/build/BUILD/Mesa-6.5/src/glx/x11'
Makefile:93: depend: No such file or directory
touch depend
makedepend -fdepend -I. -I../../../include -I../../../include/GL/internal
-I../../../src/mesa/main -I../../../src/mesa/glapi
-I../../../src/mesa/drivers/dri/common `pkg-config --cflags libdrm` 
glcontextmodes.c clientattrib.c compsize.c eval.c glxcmds.c glxext.c
glxextensions.c indirect.c indirect_init.c indirect_size.c indirect_window_pos.c
indirect_transpose_matrix.c indirect_vertex_array.c indirect_vertex_program.c
pixel.c pixelstore.c render2.c renderpix.c single2.c singlepix.c vertarr.c
xfont.c glx_pbuffer.c glx_query.c glx_texture_compression.c dri_glx.c XF86dri.c \
	../../../src/mesa/main/dispatch.c ../../../src/mesa/glapi/glapi.c
../../../src/mesa/glapi/glthread.c ../../../src/mesa/x86-64/glapi_x86-64.S 
/bin/sh: makedepend: command not found
make[3]: *** [depend] Error 127
make[3]: Leaving directory `/builddir/build/BUILD/Mesa-6.5/src/glx/x11'
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/Mesa-6.5/src'
make[1]: *** [default] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/Mesa-6.5'
make: *** [linux-dri-x86-64] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.42010 (%build)



Attached is a patch adding the necessary BuildRequire: imake line.
Comment 1 Andreas Thienemann 2006-05-16 12:27:06 EDT
Created attachment 129226 [details]
Patch, adding the missing buildreqs
Comment 2 Mike A. Harris 2006-05-17 16:21:10 EDT
This is not quite correct.  In the error output, it is "makedepend" that it
is invoking and can not find.  Mesa does not appear to use "imake" anywhere.

The correct dependency is:

BuildRequires: makedepend


Note:  Each of the modular X packages contains a virtual provide for each
binary that is in the package which another package may potentially depend
upon.  The purpose of this is to allow other packages to depend on the
individual binaries they require, which will follow the binary from package
to package if it is later moved to some other package - rather than depending
on the package the binary currently happens to be contained within.

In other words, do not depend on "imake" unless a package actually invokes
the "imake" binary itself.  Depend on the specific binary you require.  If
it turns out that a package is missing a virtual provide for a given binary,
file another bug report for that, and we can add the missing virtual provide
in the next build, for other packages to depend upon.
Comment 3 Mike A. Harris 2006-05-17 16:27:51 EDT
Fixed in 6.5-6 in rawhide.
Comment 4 Mike A. Harris 2006-05-17 16:44:18 EDT
Also checked into FC-5 CVS branch head.
Comment 5 Fedora Update System 2006-06-26 19:04:15 EDT
mesa-6.4.2-6.FC5.3 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 Fedora Update System 2006-06-28 09:49:02 EDT
mesa-6.4.2-6.FC5.3 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.