Bug 1919696 - Fedora Kde Plasma spin won't boot anymore after latest sddm update
Summary: Fedora Kde Plasma spin won't boot anymore after latest sddm update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sddm
Version: 33
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-24 18:54 UTC by carobinario
Modified: 2021-01-30 17:56 UTC (History)
11 users (show)

Fixed In Version: sddm-0.19.0-5.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-30 01:54:40 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description carobinario 2021-01-24 18:54:33 UTC
Description of problem:
Hi, I’m using Fedora 33 Kde spin. This morning I updated my system with sudo dnf update. Dnf installed 8-10 packages (one was ssdm), than I powered off my system. Thirty minutes ago I powered on my desktop but, after grub, it won’t boot anymore! I can only see, after grub selection, the Fedora logo for about 5-6 seconds, than a black screen appears.

I think it's a critical bug related to latest commit to sddm (sddm-0.19.0-3.fc33) https://src.fedoraproject.org/rpms/sddm/c/0d68a0fd96e204c3eb28030ec5e460e5c6bbf67f?branch=master

In fact in the Xorg.1.log I find:
[ 22408.303] (EE) Failed to open authorization file "/var/run/sddm/{d719c9f1-35a0-4f30-b0b4-582d940655b9}": No such file or directory

I found a workaround to login in my Plasma desktop: install GDM, disable sddm, enable gdm.

Comment 1 Chris Perrault 2021-01-27 04:28:38 UTC
Just adding that I ran into this too. GDM worked after I installed it, but SDDM just gave me the same blank screen(you can switch to other VCs to get in though).
My fix for now is actually to downgrade from sddm.0.19.0-3.fc33 to sddm.0.18.1-8.fc33 which is working. 

I too am am running the KDE spin which I just upgraded to Fedora 33 via dnf upgrade.

Comment 2 Rex Dieter 2021-01-27 05:10:40 UTC
What video driver do you use?
Do you use autologin feature?

Comment 3 Fedora Update System 2021-01-27 05:11:11 UTC
FEDORA-2021-b71b8a85c8 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-b71b8a85c8

Comment 4 damian.true2 2021-01-27 06:46:16 UTC
I got similar or identical bug too. After dnf update I can not open desktop, I see only black screen after fedora loads. I have enabled autologin. 
That's my journal log: https://pastebin.com/WyD5F2TG. Sddm exited with 1.

Comment 5 carobinario 2021-01-27 19:55:06 UTC
(In reply to Rex Dieter from comment #2)
> What video driver do you use?
> Do you use autologin feature?

Hi, I use integrated Intel driver (Intel HD 530) and no, I don't use autologin.

Comment 6 jacco 2021-01-27 22:59:19 UTC
I do use the autologin feature.
I think that the issue is fixed upstream: https://github.com/sddm/sddm/pull/1355/commits

I rebuild the sddm rpm locally with that patch added and the machine booted normal after install.

Comment 7 Fedora Update System 2021-01-28 01:53:50 UTC
FEDORA-2021-b71b8a85c8 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-b71b8a85c8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-b71b8a85c8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 jacco 2021-01-28 08:21:31 UTC
The proposed update does not fix my issue. The machine still does not boot with autologin enabled.

Comment 9 Fedora Update System 2021-01-28 14:47:35 UTC
FEDORA-2021-b71b8a85c8 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-b71b8a85c8

Comment 10 carobinario 2021-01-28 15:51:55 UTC
(In reply to Fedora Update System from comment #9)
> FEDORA-2021-b71b8a85c8 has been submitted as an update to Fedora 33.
> https://bodhi.fedoraproject.org/updates/FEDORA-2021-b71b8a85c8

This update fixed the bug on my Plasma 5.20.5 with Kde Frameworks 5.78.0, Qt 5.15.2. Thanks.

Comment 11 Tom Horsley 2021-01-28 23:09:43 UTC
I wonder if Bug 1893392 is a different manifestation of the same problem? Something weird certainly seems to be going on with sddm.

Comment 12 Fedora Update System 2021-01-29 02:01:28 UTC
FEDORA-2021-b71b8a85c8 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-b71b8a85c8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-b71b8a85c8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 jacco 2021-01-29 09:11:29 UTC
sddm-0.19.0-5.fc33.x86_64 fixes my issue,
thanks!

Comment 14 Fedora Update System 2021-01-30 01:54:40 UTC
FEDORA-2021-b71b8a85c8 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 jjohnson6 2021-01-30 16:06:44 UTC
Unfortunately the above solution still doesn’t work for me.

I’m running Fedora 33 on a VMWare Workstation 16 on a Windows 10 PC.  I've actually tried this on two different Windows 10 PCs.  Also using Plasma 5.20.5 with Kde Frameworks 5.78.0, Qt 5.15.2

When I log in I get a ksplashqml (The KDE Crash Handler) error message, and a couple xterm windows that are part of my saved standard setup, but no Plasma background (just black) or taskbar. The xterms enable the machine to function, but this all occurred as the result of a recent (Jan. 27?) dnf update. At the time my first indication of a problem was when I was unable to logout using the KDE’s “Leave” option, and had to resort to a “sudo shutdown”.

I’ve tried upgrading to sddm-0.19.0-5 (using the above update), but no luck there. I’ve also tried removing ~/.cache but no luck.

I also experimented by installing a completely fresh version of Fedora 33 using VMWare Workstation (followed by “sudo dnf install kde”, and then choosing kde (Plasma) during login). But I got the same ksplashqml error screen and no Plasma background/toolbar. The fact that KDE on Fedora 33 doesn’t work “fresh out of the box” anymore seems to be a larger problem here.

Comment 16 Rex Dieter 2021-01-30 17:56:21 UTC
There are multiple issues, this one was primarily about session types (which mostly affected autologin feature).

VMWare-related issues are being tracked in separate bug #1921523


Note You need to log in before you can comment on or make changes to this bug.