Bug 191974 - Oops in show_map running fuser
Oops in show_map running fuser
Status: CLOSED DUPLICATE of bug 189260
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-16 13:19 EDT by Chris Adams
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 13:06:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full kernel log with two oopses and boot messages (52.26 KB, text/plain)
2006-05-16 13:19 EDT, Chris Adams
no flags Details

  None (edit)
Description Chris Adams 2006-05-16 13:19:52 EDT
Created attachment 129238 [details]
full kernel log with two oopses and boot messages
Comment 1 Chris Adams 2006-05-16 13:19:52 EDT
I just oopsed the same server twice in a row using fuser.  I have a script that
goes through a sendmail queue and looks for any bad queue files (left behind by
killed processes, etc.), and it runs fuser on the queue files looking to see if
sendmail is accessing them.  The system oopsed and hung, I rebooted it and ran
the script again, and the system died again.

Here is the oops (and the full kernel log for today will be attached):

Unable to handle kernel NULL pointer dereference at virtual address 000001b8
 printing eip:
c018548c
*pde = 289f0001
Oops: 0000 [#1]
SMP 
Modules linked in: button battery ac ohci_hcd e100 mii floppy dm_snapshot
dm_zero dm_mirror ext3 jbd dm_mod megaraid_mbox megaraid_mm sd_mod scsi_mod
CPU:    1
EIP:    0060:[<c018548c>]    Not tainted VLI
EFLAGS: 00010246   (2.6.9-34.ELsmp) 
EIP is at show_map+0x70/0x111
eax: 00000000   ebx: cd790a6c   ecx: 000000fd   edx: e2619990
esi: 00100073   edi: f4b76420   ebp: f3cbae20   esp: d3f18f24
ds: 007b   es: 007b   ss: 0068
Process fuser (pid: 18574, threadinfo=d3f18000 task=d01b4d30)
Stack: 00000070 0000e000 000000fd 00000003 00043cfe d3f18f40 e2619990 c032c980 
       c032c980 f4b76420 00000000 cd790a6c c0174680 0000019d 00000000 00000400 
       b7d00000 00000006 00000000 00000005 00000000 c032ce60 e7abca60 00000400 
Call Trace:
 [<c0174680>] seq_read+0x1c7/0x2c2
 [<c015a43d>] vfs_read+0xb6/0xe2
 [<c015a650>] sys_read+0x3c/0x62
 [<c02d2657>] syscall_call+0x7/0xb
 [<c02d007b>] schedule+0x32f/0x8d3
Code: c1 e0 0c 50 89 f0 24 80 3c 01 19 c0 83 e0 fd 83 c0 73 f7 c6 04 00 00 00 50
75 1b 83 3d bc 11 41 c0 00 75 19 8b 54 24 18 8b 42 70 <8b> 80 b8 01 00 00 39 43
04 73 07 b8 78 00 00 00 eb 05 b8 2d 00 
 <0>Fatal exception: panic in 5 seconds
Comment 2 Jason Baron 2006-05-18 13:06:51 EDT

*** This bug has been marked as a duplicate of 189260 ***
Comment 3 Jason Baron 2006-05-18 13:11:25 EDT
the U4 beta kernel resolves this issue, please see:

http://people.redhat.com/~jbaron/rhel4/
Comment 4 Chris Adams 2006-05-18 13:29:25 EDT
Since I'm the only person that even logs into this server, I'll take the "if it
hurts don't do that" approach until a non-beta kernel comes out.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.