This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 191983 - kdewebdev Package won't build in mock
kdewebdev Package won't build in mock
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdewebdev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-16 13:42 EDT by Andreas Thienemann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-08 16:46:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Build Log (174.88 KB, text/plain)
2006-05-16 13:42 EDT, Andreas Thienemann
no flags Details

  None (edit)
Description Andreas Thienemann 2006-05-16 13:42:16 EDT
Current kdewebdev-3.5.2-1 won'T build in mock:


g++ -DHAVE_CONFIG_H -I. -I. -I../..  -I../../kommander/widget
-I../../kommander/widgets -I../../kommander/factory -I/usr/include/kde
-I/usr/lib64/qt-3.3/include -I.  -Ishared -Iinterfaces -Ipics
-DQT_THREAD_SUPPORT  -D_REENTRANT -DKOMMANDER -DDESIGNER -DQT_NO_SQL -DHAVE_KDE
 -DNDEBUG -DNO_DEBUG -O2 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fno-exceptions
-fno-check-new -fno-common -DENABLE_CVSSERVICE  -c -o functions.o functions.cpp
/bin/sh ../../libtool --silent --tag=CXX --mode=link g++  -DNDEBUG -DNO_DEBUG
-O2 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -fno-exceptions -fno-check-new
-fno-common -DENABLE_CVSSERVICE    -o kmdr-editor  -L/usr/lib64/qt-3.3/lib
-L/usr/lib64 -Wl,--as-needed -Wl,--enable-new-dtags  actiondnd.o
actioneditorimpl.o assoctexteditorimpl.o actionlistview.o asciivalidator.o
assistproc.o command.o connectioneditorimpl.o defs.o filechooser.o formfile.o
formsettingsimpl.o formwindow.o hierarchyview.o iconvieweditorimpl.o layout.o
listboxeditorimpl.o listvieweditorimpl.o main.o mainwindow.o mainwindowactions.o
metadatabase.o multilineeditorimpl.o newformimpl.o orderindicator.o
paletteeditoradvancedimpl.o paletteeditorimpl.o parser.o pixmapchooser.o
previewframe.o previewwidgetimpl.o propertyeditor.o qcompletionedit.o resource.o
sizehandle.o styledbutton.o tableeditorimpl.o widgetdatabase.o widgetfactory.o
wizardeditorimpl.o workspace.o choosewidgetimpl.o functionsimpl.o messagelog.o
actioneditor.o assoctexteditor.o connectioneditor.o createtemplate.o
formsettings.o iconvieweditor.o listboxeditor.o listeditor.o listvieweditor.o
multilineeditor.o newform.o paletteeditor.o paletteeditoradvanced.o
pixmapfunction.o preferences.o previewwidget.o tableeditor.o wizardeditor.o
choosewidget.o functions.o ../../kommander/factory/libkommanderfactory.la
../../kommander/widget/libkommanderwidget.la
../../kommander/widgets/libkommanderwidgets.la
../../kommander/plugin/libkommanderplugin.la 
/usr/bin/ld: warning: libkommanderplugin.so.0, needed by
../../kommander/widgets/.libs/libkommanderwidgets.so, not found (try using
-rpath or -rpath-link)
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::addWidget(QString const&, QString const&, QString const&,
QString const&, bool)'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`typeinfo for KommanderPlugin'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::isContainer(QString const&) const'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::removeWidget(QString const&)'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::~KommanderPlugin()'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::qt_property(int, int, QVariant*)'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::className() const'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::widgets() const'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::KommanderPlugin()'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::qt_invoke(int, QUObject*)'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::qt_emit(int, QUObject*)'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::whatsThis(QString const&) const'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::group(QString const&) const'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::toolTip(QString const&) const'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::qt_cast(char const*)'
../../kommander/widgets/.libs/libkommanderwidgets.so: undefined reference to
`KommanderPlugin::staticMetaObject()'
collect2: ld returned 1 exit status
make[4]: *** [kmdr-editor] Error 1
make[4]: Leaving directory `/builddir/build/BUILD/kdewebdev-3.5.2/kommander/editor'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/builddir/build/BUILD/kdewebdev-3.5.2/kommander/editor'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/kdewebdev-3.5.2/kommander'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/kdewebdev-3.5.2'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.12874 (%build)


A buildlog is attached.
Comment 1 Andreas Thienemann 2006-05-16 13:42:16 EDT
Created attachment 129247 [details]
Build Log
Comment 2 Ngo Than 2006-05-16 14:40:59 EDT
strange, i don't see the cause why libkommanderwidgets.so is missing during the
build. Could you please check the space on the device?


Comment 3 Andreas Thienemann 2006-05-16 15:29:14 EDT
I just did a rebuild from scratch in mock on x86_64. There are still 12GB free
in /var/lib/mock.

So it can't be a full disk.
Comment 4 Ngo Than 2006-05-19 12:02:25 EDT
could you please try to rebuild it without %{?_smp_mflags} if it works? thanks
Comment 5 Ngo Than 2006-06-08 16:46:36 EDT
it's fixed in rawhide. thanks

Note You need to log in before you can comment on or make changes to this bug.