Bug 191988 - amarok goes into a busy loop and stops responding
Summary: amarok goes into a busy loop and stops responding
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-16 17:58 UTC by Suchandra Thapa
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-27 14:08:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Suchandra Thapa 2006-05-16 17:58:05 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  load playlist 
2.  start playing 
  
Actual results:

After a while amarok goes into a busy loop and stops responding. 


Additional info:

The error appears to be in gstreamer since the amarok sends out a bunch of
GStreamer errors on the commandline

Comment 1 Aurelien Bompard 2006-05-20 07:23:07 UTC
Is it a playlist of local tracks, or is it streaming ?
Could you try with the Helix engine ?

Comment 2 Suchandra Thapa 2006-05-20 19:20:33 UTC
The playlist is local tracks.  The helix engine doesn't support mp3 tracks so it
wouldn't be applicable but I've recreated the  amarok rpm with support for the
xine engine and it has worked without problems when I installed and used that. 

I've previously attached gdb to a busy process and got a backtrace but didn't
record it.  I'll try to reinstall the original rpm and try that again.  This is
on  a dual processor machine so I might be hitting a race condition since it
happens at random times.

Comment 3 Aurelien Bompard 2006-05-27 14:08:15 UTC
OK, the gstreamer engine is not quite finished in Amarok, which is why they
removed it from the final 1.4 tarball. If the xine engine works for you, then fine.


Note You need to log in before you can comment on or make changes to this bug.