Bug 191989 - sending break to serial console hangs system
sending break to serial console hangs system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: Reopened
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-05-16 14:03 EDT by Doug Chapman
Modified: 2015-01-04 17:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 15:19:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2006-05-16 14:03:24 EDT
Description of problem:
Serial consoles use "break" in place of the sysrq key.  Sending a break on my HP
Integrity servers via the remote console hangs the system to the point where the
system does not even respond to ping.  This makes it nearly impossible to debug
hang situations.

If the system is alive sending a character to /proc/sysrq-trigger still does
work OK so this appears to be a serial console issue rather than a sysrq issue.

Version-Release number of selected component (if applicable):
kernel-2.6.16-1.2203_FC6
(note, this is the first I have tried this on rawhide so I do not know when this
last worked)


How reproducible:
100%

Steps to Reproduce:
1. connect to an HP Integrity server via telnet to the MP
2. log in to the MP
3. type "co" to connect to the console
4. send a break using telnet: <ctrl>-] then "send break"

  
Actual results:
system hangs

Expected results:


Additional info:
Comment 1 Dave Jones 2006-06-23 00:06:10 EDT
I think this was due to the kgdb patches I was experimenting with.
It's likely this is fixed now, as they've been reverted.
Comment 2 Doug Chapman 2006-06-23 10:32:24 EDT
Appears that this is a different problem.  I am still seeing the hang on
2.6.16-1.2289_FC6.  Please let me know if there is something I can do to provide
more info that would be useful.
Comment 3 Doug Chapman 2006-07-05 16:20:20 EDT
FYI, a little more info...

If you do not have the sysrq key enabled a "break" does not cause the hang. 
But, if sysrq key is enabled (i.e. by adding kernel.sysrq = 1 to
/etc/sysctl.conf) we get then hang when we send a "break".

Comment 4 Doug Chapman 2006-08-31 15:19:21 EDT
This appears to be working now.  Verified in 2.6.17-1.2600.fc6.

Note You need to log in before you can comment on or make changes to this bug.