Bug 192012 - Package won't build in mock
Package won't build in mock
Status: CLOSED DUPLICATE of bug 191529
Product: Fedora
Classification: Fedora
Component: glibc-kernheaders (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-16 15:56 EDT by Andreas Thienemann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-17 05:30:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Bu ild Log (78.83 KB, text/plain)
2006-05-16 15:56 EDT, Andreas Thienemann
no flags Details

  None (edit)
Description Andreas Thienemann 2006-05-16 15:56:08 EDT
iproute won#t build in mock:

+ install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc /var/tmp/iproute-2.6.16-root/sbin
install: cannot stat `ip/ip': No such file or directory
install: cannot stat `ip/rtmon': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.49753 (%install)


There seems to be a problem with a glibc-kernheaders file, not being found, even
though it is installed into the chroot.

gcc -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -I../include
-DRESOLVE_HOSTNAMES   -c -o
iproute.o iproute.c
iproute.c:30:28: error: linux/in_route.h: No such file or directory
iproute.c: In function 'print_route':
iproute.c:409: error: 'RTCF_LOCAL' undeclared (first use in this function)
iproute.c:409: error: (Each undeclared identifier is reported only once
iproute.c:409: error: for each function it appears in.)
iproute.c:410: error: 'RTCF_REJECT' undeclared (first use in this function)
iproute.c:411: error: 'RTCF_MULTICAST' undeclared (first use in this function)
iproute.c:412: error: 'RTCF_BROADCAST' undeclared (first use in this function)
iproute.c:413: error: 'RTCF_DNAT' undeclared (first use in this function)
iproute.c:414: error: 'RTCF_SNAT' undeclared (first use in this function)
iproute.c:415: error: 'RTCF_MASQ' undeclared (first use in this function)
iproute.c:416: error: 'RTCF_DIRECTDST' undeclared (first use in this function)
iproute.c:417: error: 'RTCF_DIRECTSRC' undeclared (first use in this function)
iproute.c:418: error: 'RTCF_REDIRECTED' undeclared (first use in this function)
iproute.c:419: error: 'RTCF_DOREDIRECT' undeclared (first use in this function)
iproute.c:420: error: 'RTCF_FAST' undeclared (first use in this function)
iproute.c:421: error: 'RTCF_NOTIFY' undeclared (first use in this function)
iproute.c:422: error: 'RTCF_TPROXY' undeclared (first use in this function)
make[1]: *** [iproute.o] Error 1


BuildLog is attached.
Comment 1 Andreas Thienemann 2006-05-16 15:56:09 EDT
Created attachment 129263 [details]
Bu ild Log
Comment 2 Radek Vokal 2006-05-17 04:44:41 EDT
I really don't understand what the bug should be here. Should I builrequire
glibc-kernheaders? I guess not. Any clue? CCing glibc-kernheaders maintainer .. 
Comment 3 David Woodhouse 2006-05-17 05:30:15 EDT
This is a glibc-kernheaders bug, unrelated to BuildRequires. It should include
this file; it didn't.

Fixed in glibc-kernheaders-3.0-33
Comment 4 Andreas Thienemann 2006-05-17 07:36:15 EDT
(In reply to comment #2)
> I really don't understand what the bug should be here. Should I builrequire
> glibc-kernheaders? I guess not. Any clue? CCing glibc-kernheaders maintainer .. 
Radek, did I put that bug as iproute? sorry, should have been glibc-kernheaders.
You won't need to BuildRequire: glibc-kernheaders. They are installed by default
into the Buildroot.
Comment 5 Brian Pepple 2006-05-17 19:38:35 EDT

*** This bug has been marked as a duplicate of 191529 ***

Note You need to log in before you can comment on or make changes to this bug.