Bug 192017 - LTC23921-FC5 reports IOError in rescue mode
LTC23921-FC5 reports IOError in rescue mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-16 16:20 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-21 15:56:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2006-05-16 16:20:01 EDT
LTC Owner is: dmosby@us.ibm.com
LTC Originator is: shenlinf@cn.ibm.com


Problem description:
I was testing rescue of FC5 May1 on greenlp1. After the system ran into rescue
mode, I pressed OK to get a shell. FC5 reported:
-----------
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 598, in ?
    rescue.runRescue(opts.rootPath, not opts.rescue_nomount, id)
  File "/usr/lib/anaconda/rescue.py", line 464, in runRescue
    runShell()
  File "/usr/lib/anaconda/rescue.py", line 172, in runShell
    fcntl.ioctl(0, termios.TIOCSCTTY)
IOError: [Errno 1] Operation not permitted
-----------


If this is a customer issue, please indicate the impact to the customer:


If this is not an installation problem,
       Describe any custom patches installed.

       Provide output from "uname -a", if possible:


Hardware Environment
    Machine type (p650, x235, SF2, etc.): Squadron ML8+
    Cpu type (Power4, Power5, IA-64, etc.): Power5
    Describe any special hardware you think might be relevant to this problem:


Please provide contact information if the submitter is not the primary contact.
My backups are Shaowu Yang(shaowu@us.ibm.com) in Austin and Changhai
Jiang(jiangchh@cn.ibm.com) in China.


Please provide access information for the machine if it is available.


Is this reproducible?
    If so, how long does it (did it) take to reproduce it?
    Describe the steps:
    1. bring up the existing FC5 system
    2. copy ramdisk.image.gz and vmlinuz from installation server to /boot on
greenlp1
    3. add an entry in /etc/yaboot.conf
    ----------
image=/vmlinuz
        label=rescue
        initrd=/ramdisk.image.gz
        read-only
        append="rescue"
    ----------
    4. reboot the system and select "rescue" in yaboot prompt
    5. config network for client and installation server
    6. FC5 runs into rescure mode
    7. press "Continue", select system to rescue and then press OK
    8. You will see the error

    If not, describe how the bug was encountered:


Is the system (not just the application) hung?
    If so, describe how you determined this:


Did the system produce an OOPS message on the console?
    If so, copy it here:


Is the system sitting in a debugger right now?
    If so, how long may it stay there?


Additional information:
1. Press "Continue" in this window
            ©°©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©È Rescue
©À©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©´
            ©¦                                                     ©¦
            ©¦ The rescue environment will now attempt to find   ¡ü ©¦
            ©¦ your Linux installation and mount it under the    ? ©¦
            ©¦ directory /mnt/sysimage.  You can then make any   ? ©¦
            ©¦ changes required to your system.  If you want     ? ©¦
            ©¦ to proceed with this step choose 'Continue'.      ? ©¦
            ©¦ You can also choose to mount your file systems    ? ©¦
            ©¦ read-only instead of read-write by choosing       ? ©¦
            ©¦ 'Read-Only'.                                      ? ©¦
            ©¦                                                   ? ©¦
            ©¦ If for some reason this process fails you can     ? ©¦
            ©¦ choose 'Skip' and this step will be skipped and   ? ©¦
            ©¦ you will go directly to a command shell.          ¡ý ©¦
            ©¦                                                     ©¦
            ©¦   ©°©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©´      ©°©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©´     
©°©¤©¤©¤©¤©¤©¤©´     ©¦
            ©¦   ©¦ Continue ©¦      ©¦ Read-Only ©¦      ©¦ Skip ©¦     ©¦
            ©¦   ©¸©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¼      ©¸©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¼     
©¸©¤©¤©¤©¤©¤©¤©¼     ©¦
            ©¦                                                     ©¦
            ©¦                                                     ©¦
           
©¸©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¼

2. select sda5 in this window
                      ©°©¤©¤©¤©¤©¤©¤©¤©È System to Rescue ©À©¤©¤©¤©¤©¤©¤©¤©´
                      ©¦                                  ©¦
                      ©¦ What partition holds the root    ©¦
                      ©¦ partition of your installation?  ©¦
                      ©¦                                  ©¦
                      ©¦              sda5                ©¦
                      ©¦              sdb5                ©¦
                      ©¦                                  ©¦
                      ©¦     ©°©¤©¤©¤©¤©´         ©°©¤©¤©¤©¤©¤©¤©´      ©¦
                      ©¦     ©¦ OK ©¦         ©¦ Exit ©¦      ©¦
                      ©¦     ©¸©¤©¤©¤©¤©¼         ©¸©¤©¤©¤©¤©¤©¤©¼      ©¦
                      ©¦                                  ©¦
                      ©¦                                  ©¦
                     
©¸©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¼

3. Click on "OK" in this window
                  ©°©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©È Rescue
©À©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©´
                  ©¦                                         ©¦
                  ©¦ Your system has been mounted under      ©¦
                  ©¦ /mnt/sysimage.                          ©¦
                  ©¦                                         ©¦
                  ©¦ Press <return> to get a shell. If you   ©¦
                  ©¦ would like to make your system the      ©¦
                  ©¦ root environment, run the command:      ©¦
                  ©¦                                         ©¦
                  ©¦         chroot /mnt/sysimage            ©¦
                  ©¦                                         ©¦
                  ©¦ The system will reboot automatically    ©¦
                  ©¦ when you exit from the shell.           ©¦
                  ©¦                                         ©¦
                  ©¦                 ©°©¤©¤©¤©¤©´                  ©¦
                  ©¦                 ©¦ OK ©¦                  ©¦
                  ©¦                 ©¸©¤©¤©¤©¤©¼                  ©¦
                  ©¦                                         ©¦
                  ©¦                                         ©¦
                 
©¸©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¤©¼

4. show error messages
--------
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 598, in ?
    rescue.runRescue(opts.rootPath, not opts.rescue_nomount, id)
  File "/usr/lib/anaconda/rescue.py", line 464, in runRescue
    runShell()
  File "/usr/lib/anaconda/rescue.py", line 172, in runShell
    fcntl.ioctl(0, termios.TIOCSCTTY)
IOError: [Errno 1] Operation not permitted
sending termination signals...done
sending kill signals...done
Comment 1 IBM Bug Proxy 2006-05-30 01:07:20 EDT
----- Additional Comments From shenlinf@cn.ibm.com  2006-05-30 01:12 EDT -------
still not fixed in May 26 version. 
Comment 2 IBM Bug Proxy 2006-06-06 03:20:04 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Version|FC5                         |devel




------- Additional Comments From shenlinf@cn.ibm.com  2006-06-06 03:21 EDT -------
I am changing the version to 'devel' to properly reflect that this recreates on
rawhide. 
Comment 3 IBM Bug Proxy 2006-10-10 07:42:57 EDT
----- Additional Comments From shenlinf@cn.ibm.com  2006-10-10 07:37 EDT -------
Didn't see this error in rescue mode with fc6-test3.
------
[root@auroralp2 ~]# uname -r
2.6.17-1.2630.fc6 
Comment 4 IBM Bug Proxy 2007-01-17 15:55:54 EST
----- Additional Comments From kcs@us.ibm.com  2007-01-17 15:53 EDT -------
Red Hat Bugzilla 192017 indicates that it is CLOSED, but there are no comments
in this bug report to indicate work was done. Red Hat, is this fixed? In FC6?
FC7? Was this bug mistakenly CLOSED? 
Comment 5 IBM Bug Proxy 2007-01-26 16:20:35 EST
----- Additional Comments From kcs@us.ibm.com  2007-01-26 16:16 EDT -------
Red Hat Engineers: Could you please comment on the resolution of Bugzilla
192017. There are no comments in this bug report to indicate that the bug was
fixed other than the bug is marked CLOSED. Was it fixed?

Also, what does the external resolution of "RAWHIDE" mean to us? Was this fixed
in FC6? FC7? Please comment on how we should interpret "RAWHIDE".

Thank you. 
Comment 6 David Cantrell 2007-01-29 10:54:26 EST
RAWHIDE is synonymous with the Fedora Development tree.  When we close an
_anaconda_ bug as CLOSED RAWHIDE, it means we've fixed it in the anaconda CVS
tree and our fix will be present in the next build of anaconda.  This may or may
not occur on the same day that we commit the fix to CVS because we don't always
rebuild anaconda after a single fix (otherwise we'd be building it thousands of
times).

The rawhide summary emails that go to the fedora-devel-list indicate what new
packages are present as well as the new changelog entries from the RPM spec
files.  Here is a sample:
https://www.redhat.com/archives/fedora-devel-list/2007-January/msg01499.html

If a bug you reported has been marked as CLOSED RAWHIDE, look at the rawhide
summary reports that go out daily.  When anaconda next appears in that list, it
means we've rebuilt it.  We put all bug numbers in the changelog for anaconda,
so you can check the summary to see yours in there.
Comment 7 IBM Bug Proxy 2007-01-30 00:00:44 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ACCEPTED                    |CLOSED




------- Additional Comments From shenlinf@cn.ibm.com  2007-01-29 23:58 EDT -------
Mark it as closed. Thank you all! 

Note You need to log in before you can comment on or make changes to this bug.