Bug 1920198 - 389-ds-base breaks on upgrade from F32 to F33 because F32 build had gost support but F33 build doesn't
Summary: 389-ds-base breaks on upgrade from F32 to F33 because F32 build had gost supp...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: 389-ds-base
Version: 33
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: mreynolds
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-25 18:24 UTC by Adam Williamson
Modified: 2021-01-27 01:18 UTC (History)
4 users (show)

Fixed In Version: 389-ds-base-1.4.4.11-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-27 01:18:42 UTC
Type: Bug


Attachments (Terms of Use)
/var/log tarball from the server from a failed test (5.02 MB, application/octet-stream)
2021-01-25 18:25 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2021-01-25 18:24:05 UTC
Recently the openQA test that tests upgrading a FreeIPA deployment (server+client) from F32 to F33 started failing for all F33 updates. From the logs, it looks like the issue is that 389-ds-base-1.4.3.18-1.fc32 went stable recently for F32. That build adds gost support. 1.4.4.10 - which adds gost support to the 1.4.4 series - was supposed to go to F33 at the same time or earlier, but was unpushed due to another issue. So currently we have a gost-capable 389-ds-base in F32 stable, but not in F33 stable. It seems like this causes things to break permanently (not just until server restart, as ab hoped) when upgrading. The logs for every attempt to start the dirsrv service after upgrade show these errors:

Jan 24 20:20:39 ipa001.test.openqa.fedoraproject.org ns-slapd[949]: [24/Jan/2021:23:20:39.284073428 -0500] - ERR - symload_report_error - Netscape Portable Runtime error -5975: /usr/lib64/dirsrv/plugins/libpwdstorage-plugin.so: undefined symbol: gost_yescrypt_pwd_storage_scheme_init
Jan 24 20:20:39 ipa001.test.openqa.fedoraproject.org ns-slapd[949]: [24/Jan/2021:23:20:39.285985054 -0500] - ERR - symload_report_error - Could not load symbol "gost_yescrypt_pwd_storage_scheme_init" from "libpwdstorage-plugin" for plugin GOST_YESCRYPT

Attaching the full tarball of /var/log from a failed test for reference.

Comment 1 Adam Williamson 2021-01-25 18:25:13 UTC
Created attachment 1750684 [details]
/var/log tarball from the server from a failed test

Comment 2 Fedora Update System 2021-01-26 07:47:17 UTC
FEDORA-2021-5258e9cb11 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-5258e9cb11

Comment 3 Fedora Update System 2021-01-27 01:18:42 UTC
FEDORA-2021-5258e9cb11 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.