Bug 192028 - The line "network --bootproto dhcp" should be included in the kickstart by default.
The line "network --bootproto dhcp" should be included in the kickstart by de...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin A. Smith
Beth Nackashi
:
Depends On:
Blocks: rhn410-kickstart
  Show dependency treegraph
 
Reported: 2006-05-16 18:01 EDT by John Wregglesworth
Modified: 2007-10-29 22:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn410
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 16:08:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Wregglesworth 2006-05-16 18:01:24 EDT
Description of problem: I've been working on getting FC5 to kickstart through a
410 satellite since it's the closest we have to RHEL 5 at the moment, but ran
into a problem. The line "network --bootproto dhcp" isn't included in the
kickstart file by default, so the FC 5 anaconda keeps dropping from an automated
install to a manual install when it reaches the network configuration step. I
don't know if this is a problem for RHEL 4.

How reproducible: Always


Steps to Reproduce:
1. Create an external distribution of FC5.
2. Create a new profile with default values that uses the distribution.
3. View the kickstart file that's generated and see that the network
configuration line isn't included.
  
Actual results: Anaconda on FC5 will switch to manual configuration when it
reaches the network configuration step.


Expected results: The kickstart file should have the line "network --bootproto
dhcp" in it to keep anaconda from dropping into manual mode.

Additional info: I can work around this by adding the network config line via
the Advanced Options.
Comment 1 Kevin A. Smith 2006-05-17 09:27:34 EDT
According to the Sysadmin Guide the network option is optional. Anaconda will
default to DHCP if nothing else is specified. This has been verified back to 2.1.
Comment 2 Kevin A. Smith 2006-05-17 11:18:41 EDT
Added code to add network --bootproto as a default option to the kickstart
Comment 3 Kevin A. Smith 2006-06-14 08:40:04 EDT
Testing Suggestion - See originating comment for a reasonable test plan.
Comment 4 Beth Nackashi 2006-06-17 22:57:47 EDT
verified on hosted and satellite (rhn-java* and taskomatic -692) for RHEL2.1,
RHEL3, and RHEL4
Comment 5 Beth Nackashi 2006-07-19 16:08:32 EDT
moving to closed - currentrelease

Note You need to log in before you can comment on or make changes to this bug.