Bug 192038 - xorg-x11-fonts Missing BuildRequire on fontconfig
Summary: xorg-x11-fonts Missing BuildRequire on fontconfig
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-fonts   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: BuildReqBlocker
TreeView+ depends on / blocked
 
Reported: 2006-05-16 23:23 UTC by Andreas Thienemann
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-26 17:44:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch, adding the missing buildreqs (435 bytes, patch)
2006-05-16 23:23 UTC, Andreas Thienemann
no flags Details | Diff

Description Andreas Thienemann 2006-05-16 23:23:45 UTC
Building the package in mock fails:

make[2]: Entering directory
`/builddir/build/BUILD/xorg-x11-fonts-7.0/font-adobe-utopia-type1-1.0.1'
/usr/bin/mkfontscale
/var/tmp/xorg-x11-fonts-7.0-3-buildroot/usr/share/X11/fonts/Type1
/usr/bin/mkfontdir /var/tmp/xorg-x11-fonts-7.0-3-buildroot/usr/share/X11/fonts/Type1
/var/tmp/xorg-x11-fonts-7.0-3-buildroot/usr/share/X11/fonts/Type1
make[2]: execvp:
/var/tmp/xorg-x11-fonts-7.0-3-buildroot/usr/share/X11/fonts/Type1: Permission denied
make[2]: *** [install-data-hook] Error 127
make[2]: Leaving directory
`/builddir/build/BUILD/xorg-x11-fonts-7.0/font-adobe-utopia-type1-1.0.1'
make[1]: *** [install-data-am] Error 2
make[1]: Leaving directory
`/builddir/build/BUILD/xorg-x11-fonts-7.0/font-adobe-utopia-type1-1.0.1'
make: *** [install-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.57487 (%install)

Normally, the makefile would call 
$(FCCACHE) /var/tmp/xorg-x11-fonts-7.0-3-buildroot/usr/share/X11/fonts/Type1
but as $(FCCACHE) is undefined due to no fc-cache binary being installed, it
just tries to execute
/var/tmp/xorg-x11-fonts-7.0-3-buildroot/usr/share/X11/fonts/Type1 which
naturally fails.

Installing fontconfig fixes this.

Attached is a pathc, adding the necessary BuildRequirement.

Comment 1 Andreas Thienemann 2006-05-16 23:23:46 UTC
Created attachment 129284 [details]
Patch, adding the missing buildreqs

Comment 2 Mike A. Harris 2006-05-23 13:55:26 UTC
There is no reason for the makefiles to be invoking fc-cache at build time.
That introduces a totally unnecessary dependency on fontconfig.

The proper fix is to patch out fc-cache from being invoked at all.  We can
do that in a future build.

I'd recommend reporting this to X.Org bugzilla also, to have the fc-cache
call removed upstream.

Comment 3 Mike A. Harris 2006-05-26 17:26:38 UTC
Ugh.  That means patching each individual font tarball, and reinvoking
autotools on each one, and then having to adjust the patch every time
upstream changes one of the font tarballs.

Since that would be a maintenance nightmare, I've decided to just add
the dependency on fontconfig instead, although I think upstream should
not be invoking fc-cache at all.



Comment 4 Mike A. Harris 2006-05-26 17:44:26 UTC
* Fri 26 May 2006 Mike A. Harris <mharris@redhat.com> 7.0-4
- Added "BuildRequires: fontconfig" for (#192038)




Note You need to log in before you can comment on or make changes to this bug.