Bug 192039 - Exception starting xend ((111, 'Connection refused')) after upgrading to kernel-xen0-2.6.16-1.2111_FC5
Exception starting xend ((111, 'Connection refused')) after upgrading to kern...
Status: CLOSED DUPLICATE of bug 190899
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-16 19:30 EDT by Aleksander Adamowski
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-17 08:14:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Aleksander Adamowski 2006-05-16 19:30:09 EDT
Description of problem:

After upgrading to the latest kernel (kernel-xen0-2.6.16-1.2111_FC5) using yum,
xend stopped working. Booting to the previous kernel
(kernel-xen0-2.6.16-1.2096_FC5) solves the problem.

The architecture is x86_64 - I'm running it on a 2 x dual core Opteron HP DL385
server.

Version-Release number of selected component (if applicable):

xen-3.0.1-4


How reproducible:

Always

Steps to Reproduce:
1. Upgrade domain0's kernel to version 2.6.16-1.2111_FC5
2. Reboot

Xend fails to start up.

Additional info:

On the new kernel, xend logs the following errors in /var/log/xend.log:

[2006-05-17 01:10:19 xend] INFO (SrvDaemon:285) Xend Daemon started
[2006-05-17 01:10:19 xend] INFO (SrvDaemon:289) Xend changeset: unavailable .
[2006-05-17 01:10:19 xend] ERROR (SrvDaemon:299) Exception starting xend ((111,
'Connection refused'))
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvDaemon.py", line
293, in run
    servers = SrvServer.create()
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvServer.py", line
106, in create
    root.putChild('xend', SrvRoot())
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvRoot.py", line 40,
in __init__
    self.get(name)
  File "/usr/lib64/python2.4/site-packages/xen/web/SrvDir.py", line 82, in get
    val = val.getobj()
  File "/usr/lib64/python2.4/site-packages/xen/web/SrvDir.py", line 52, in getobj
    self.obj = klassobj()
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvDomainDir.py",
line 39, in __init__
    self.xd = XendDomain.instance()
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomain.py", line 550, in
instance
    inst.init()
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomain.py", line 70, in init
    xstransact.Mkdir(VMROOT)
  File "/usr/lib64/python2.4/site-packages/xen/xend/xenstore/xstransact.py",
line 317, in Mkdir
    complete(path, lambda t: t.mkdir(*args))
  File "/usr/lib64/python2.4/site-packages/xen/xend/xenstore/xstransact.py",
line 323, in complete
    t = xstransact(path)
  File "/usr/lib64/python2.4/site-packages/xen/xend/xenstore/xstransact.py",
line 20, in __init__
    self.transaction = xshandle().transaction_start()
  File "/usr/lib64/python2.4/site-packages/xen/xend/xenstore/xsutil.py", line
18, in xshandle
    xs_handle = xen.lowlevel.xs.xs()
RuntimeError: (111, 'Connection refused')
Comment 1 Brian Stein 2006-05-17 08:14:34 EDT

*** This bug has been marked as a duplicate of 190899 ***

Note You need to log in before you can comment on or make changes to this bug.