Bug 192040 - xorg-x11-resutils fails to build with mock
xorg-x11-resutils fails to build with mock
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-resutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-16 19:55 EDT by Michael J Knox
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-23 01:49:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mdomsch's mock buildlog (7.94 KB, text/plain)
2006-05-16 19:55 EDT, Michael J Knox
no flags Details
configure log (11.43 KB, text/plain)
2006-06-22 16:09 EDT, Michael J Knox
no flags Details

  None (edit)
Description Michael J Knox 2006-05-16 19:55:01 EDT
Description of problem:

SRPM failed to rebuild inside of a mock chroot. 

Version-Release number of selected component (if applicable):

xorg-x11-resutils-1.0.1-1.2.src.rpm

How reproducible:

mock xorg-x11-resutils-1.0.1-1.2.src.rpm

Steps to Reproduce:
1. mock xorg-x11-resutils-1.0.1-1.2.src.rpm
2. wait for a while. 
3.
  
Actual results:

Not a successful rebuild

Expected results:

To successfully rebuild


Additional info:

checking pkg-config is at least version 0.9.0... yes
checking for TMP_XAW... configure: error: No suitable version of Xaw found
error: Bad exit status from /var/tmp/rpm-tmp.61101 (%build)
Comment 1 Michael J Knox 2006-05-16 19:55:02 EDT
Created attachment 129286 [details]
mdomsch's mock buildlog
Comment 2 Mike A. Harris 2006-05-23 10:44:52 EDT
Changing state to ASSIGNED.
Comment 3 Mike A. Harris 2006-06-06 08:00:55 EDT
The resutils spec file contains the following for a long time now:

BuildRequires: pkgconfig
BuildRequires: libX11-devel
BuildRequires: libXt-devel
BuildRequires: libXmu-devel
BuildRequires: libXext-devel
BuildRequires: libSM-devel
BuildRequires: libICE-devel
BuildRequires: libXaw-devel
# FIXME: appres has 'x11 xt' as a dependency check, which fails.  While it
# does not check for Xdmcp, installing libXdmcp-devel resolves the problem.
# This implies that one of the other library devel packages should probably
# have a Requires: libXdmcp-devel instead, but it isn't completely clear
# what the best solution is yet, so I'm putting this here.
BuildRequires: libXdmcp-devel


Both pkgconfig and libXaw-devel are listed there.  However, I just tried
to build the package in brew, and the package fails to build the same
way as reported above.  Examination of the build logs shows that mock in
fact did not install libXaw-devel, even though the rpm package states
that it is a dependency.

This appears to be a bug in mock.



Comment 4 Mike A. Harris 2006-06-06 08:54:19 EDT
I seem to have misread brew's build logs.  It turns out that libXaw is
getting installed afterall.  It appears that the ./configure test for
XAW is somehow not working in rawhide, but works fine in FC4 and FC1.

Presumeably this is breakage local to rawhide.
Comment 5 Mike A. Harris 2006-06-14 13:35:01 EDT
I totally can't reproduce this on my local test build systems whatsoever,
however it is completely reproduceable in our brew buildsystem.  It
was believed initially to be caused by libXaw not requiring "ed" at
build time, which caused libXaw to be built with incorrect soname,
but that has been fixed now aparently, and this problem still occurs.

There are more critical bugs to be working on currently, so I'm leaving
this one for now, however in the mean time, if anyone feels up to the
task of figuring out WTF is happening inside brew/mock, feel free to
fix this.

Otherwise, we'll eventually get around to it...


Comment 6 Michael J Knox 2006-06-22 16:00:16 EDT
You need to add a BuildRequires: libXpm-devel

Wrote: /builddir/build/RPMS/xorg-x11-resutils-1.0.1-1.2.i386.rpm
Wrote: /builddir/build/RPMS/xorg-x11-resutils-debuginfo-1.0.1-1.2.i386.rpm

Comment 7 Michael J Knox 2006-06-22 16:09:35 EDT
Created attachment 131382 [details]
configure log

The configure log is from editres
Comment 8 Mike A. Harris 2006-06-23 01:49:23 EDT
Thanks again Michael.  I've fixed the issue by updating the libXpm package
with a "Requires: libXpm-devel" in its devel subpackage, and rebuilding
resutils.

Should be fixed now in rawhide.

Note You need to log in before you can comment on or make changes to this bug.