Bug 192042 - xorg-x11-drv-voodoo fails to build with mock
xorg-x11-drv-voodoo fails to build with mock
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-voodoo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-16 20:14 EDT by Michael J Knox
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.1.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-28 18:57:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mdomsch's mock buildlog (9.42 KB, text/plain)
2006-05-16 20:14 EDT, Michael J Knox
no flags Details
Patch for missing BR (801 bytes, patch)
2006-05-18 09:50 EDT, Brian Pepple
no flags Details | Diff
Build log after patch (17.79 KB, text/plain)
2006-05-18 09:51 EDT, Brian Pepple
no flags Details

  None (edit)
Description Michael J Knox 2006-05-16 20:14:19 EDT
Description of problem:

xorg-x11-drv-voodoo fails to build in a mock chroot due to missing build requires

Version-Release number of selected component (if applicable):

xorg-x11-drv-voodoo-1.1.0-1.src.rpm

How reproducible:
Build with mock 

Steps to Reproduce:
1. mock xorg-x11-drv-voodoo-1.1.0-1.src.rpm
2.
3.
  
Actual results:

Build fails

Expected results:

Build should succeed

Additional info:

checking for XORG... configure: error: Package requirements (xorg-server >=
1.0.99.901 xproto fontsproto xf86dgaproto  randrproto renderproto xextproto)
were not met:

No package 'xproto' found
No package 'fontsproto' found
No package 'xf86dgaproto' found
No package 'randrproto' found
No package 'renderproto' found
No package 'xextproto' found
Comment 1 Michael J Knox 2006-05-16 20:14:20 EDT
Created attachment 129288 [details]
mdomsch's mock buildlog
Comment 2 Brian Pepple 2006-05-18 09:50:12 EDT
Created attachment 129419 [details]
Patch for missing BR
Comment 3 Brian Pepple 2006-05-18 09:51:28 EDT
Created attachment 129421 [details]
Build log after patch
Comment 4 Mike A. Harris 2006-05-23 10:37:40 EDT
Changing state to ASSIGNED.
Comment 5 Matt Domsch 2006-05-28 18:57:26 EDT
xorg-x11-drv-voodoo-1.1.0-3.src.rpm builds on i386 and x86_64.

Note You need to log in before you can comment on or make changes to this bug.