Bug 192045 - xorg-x11-drv-void fails to build with mock
xorg-x11-drv-void fails to build with mock
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-void (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-16 20:25 EDT by Michael J Knox
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 11:20:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mdomsch's mock buildlog (9.25 KB, text/plain)
2006-05-16 20:25 EDT, Michael J Knox
no flags Details
Patch for missing BR (1.03 KB, patch)
2006-05-18 09:38 EDT, Brian Pepple
no flags Details | Diff
Build log after patch (15.38 KB, text/plain)
2006-05-18 09:39 EDT, Brian Pepple
no flags Details

  None (edit)
Description Michael J Knox 2006-05-16 20:25:22 EDT
Description of problem:

xorg-x11-drv-void fails to build in a mock chroot due to missing build requires

Version-Release number of selected component (if applicable):

xorg-x11-drv-void-1.1.0-1.src.rpm

How reproducible:

Build with mock 

Steps to Reproduce:
1. mock xorg-x11-drv-void-1.1.0-1.src.rpm
2.
3.
  
Actual results:

Build fails

Expected results:

Build should succeed

Additional info:
checking for XORG... configure: error: Package requirements (xorg-server >=
1.0.99.901 xproto  randrproto inputproto) were not met:

No package 'xproto' found
No package 'randrproto' found
No package 'inputproto' found
Comment 1 Michael J Knox 2006-05-16 20:25:23 EDT
Created attachment 129289 [details]
mdomsch's mock buildlog
Comment 2 Brian Pepple 2006-05-18 09:38:52 EDT
Created attachment 129417 [details]
Patch for missing BR
Comment 3 Brian Pepple 2006-05-18 09:39:27 EDT
Created attachment 129418 [details]
Build log after patch
Comment 4 Mike A. Harris 2006-05-23 10:42:47 EDT
Changing state to ASSIGNED.
Comment 5 Adam Jackson 2006-06-01 11:20:28 EDT
fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.