Bug 192046 - xorg-x11-drv-vmware fails to build with mock
xorg-x11-drv-vmware fails to build with mock
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vmware (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-16 20:43 EDT by Michael J Knox
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 11:16:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mdomsch's mock buildlog (9.39 KB, text/plain)
2006-05-16 20:43 EDT, Michael J Knox
no flags Details
Patch for missing BR (1.02 KB, patch)
2006-05-17 23:03 EDT, Brian Pepple
no flags Details | Diff
Build log for patch (47.96 KB, text/plain)
2006-05-17 23:03 EDT, Brian Pepple
no flags Details
Patch for missing BR (1.07 KB, patch)
2006-05-17 23:18 EDT, Brian Pepple
no flags Details | Diff
Build log from patch (20.44 KB, text/plain)
2006-05-17 23:19 EDT, Brian Pepple
no flags Details

  None (edit)
Description Michael J Knox 2006-05-16 20:43:29 EDT
Description of problem:

xorg-x11-drv-vmware fails to build in a mock chroot due to missing build requires

Version-Release number of selected component (if applicable):

xorg-x11-drv-vmware-10.13.0-1.src.rpm

How reproducible:

Build with mock

Steps to Reproduce:
1. mock xorg-x11-drv-vmware-10.13.0-1.src.rpm
2.
3.
  
Actual results:

Build fails

Expected results:

Build to succeed

Additional info:

checking for XORG... configure: error: Package requirements (xorg-server >=
1.0.99.901 xproto fontsproto  randrproto renderproto xextproto) were not met:

No package 'xproto' found
No package 'fontsproto' found
No package 'randrproto' found
No package 'renderproto' found
No package 'xextproto' found
Comment 1 Michael J Knox 2006-05-16 20:43:30 EDT
Created attachment 129290 [details]
mdomsch's mock buildlog
Comment 2 Brian Pepple 2006-05-17 23:03:21 EDT
Created attachment 129388 [details]
Patch for missing BR
Comment 3 Brian Pepple 2006-05-17 23:03:56 EDT
Created attachment 129389 [details]
Build log for patch
Comment 4 Brian Pepple 2006-05-17 23:08:03 EDT
Comment on attachment 129388 [details]
Patch for missing BR

Wrong patch
Comment 5 Brian Pepple 2006-05-17 23:18:50 EDT
Created attachment 129392 [details]
Patch for missing BR
Comment 6 Brian Pepple 2006-05-17 23:19:27 EDT
Created attachment 129393 [details]
Build log from patch
Comment 7 Mike A. Harris 2006-05-23 10:31:37 EDT
Changing state to ASSIGNED.
Comment 8 Adam Jackson 2006-06-01 11:16:30 EDT
fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.