Bug 192048 - HPLIP-0.9.11 disabled usblp driver
HPLIP-0.9.11 disabled usblp driver
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-05-16 21:10 EDT by Bob Agel
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-17 10:53:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Agel 2006-05-16 21:10:19 EDT
Description of problem: Cups refuses to print after 5/16 update to
cups-1.2.0-1.1/hplip-0.9.11-1.1 ; printer is on and usb is active.  Pages and
test page show going to hp656c printer but remain 'processing' for many minutes
with no response from printer.  All worked prior to update.  Printer is
correctly identified, 'system-config-services' reports cups "running" but I
noticed that while cups usually takes a few seconds during boot to initialize,
now it is instantaneous and I did not see the 'starting cups' during boot.  Have
also checked permissions and they are fine.


Version-Release number of selected component (if applicable):


How reproducible: Any print job will fail.


Steps to Reproduce:
1. Attempt to print any job
2. K-Job viewer shows 'processing' - print manager shows all normal settings
3. No output to printer
  
Actual results:


Expected results:


Additional info:
Comment 1 Bob Agel 2006-05-16 23:26:49 EDT
Have also tried to print as root and have tried Foomatic+hpijs-rss drivers for
the HP656C instead of the Foomatic+hpijs; didn't work either.  As info, SELinux
has been disabled since installation and still reports as disabled.
Comment 2 Tim Waugh 2006-05-17 07:36:28 EDT
Please attach the output of 'printconf-tui --Xexport'.  Thanks.
Comment 3 Bob Agel 2006-05-17 10:10:12 EDT
<?xml version="1.0"?>
<adm_context VERSION="0">
  <id NAME="local" SERIAL="1147836094">
    <null/>
    <null/>
    </id>
  <datatree>
    <printconf TYPE="LIST">
      <print_queues TYPE="LIST">
        </print_queues>
      <sharing_globals TYPE="LIST">
        <browsing TYPE="BOOL" VALUE="TRUE"/>
        </sharing_globals>
      <default_queue TYPE="STRING" VALUE="hp656c"/>
      </printconf>
    </datatree>
  </adm_context>
Comment 4 Tim Waugh 2006-05-17 10:14:04 EDT
Thanks.  What does 'lpstat -s' say?
Comment 5 Bob Agel 2006-05-17 10:20:18 EDT
system default destination: hp656c
device for hp656c: usb://DESKJET/656C?serial=TH1CA1D0QJ


UPDATE:  Believe it or not, after nearly 15 minutes the first page (two lines of
text) actually printed.  I've sent another file to the print queue and am
awaiting a second page - approx 3 minutes so far on a five word text print...
so, it's now a 'speed' issue I guess.
Comment 6 Tim Waugh 2006-05-17 10:28:58 EDT
What about these commands?:

rpm -q hplip
/sbin/chkconfig --list hplip
/sbin/service hplip status
Comment 7 Bob Agel 2006-05-17 10:37:30 EDT
rpm -q hplip returns "hplip-0.9.11-1.1"

/sbin/chkconfig --list hplip returns: 
hplip           0:off   1:off   2:on    3:on    4:on    5:on    6:off


/sbin/service hplip status returns
hpiod (pid 1981) is running...
hpssd (pid 1986) is running...
 (btw, still waiting for that 5-word test print...)
Comment 8 Tim Waugh 2006-05-17 10:53:51 EDT
Okay, this is due to new behaviour since HPLIP-0.9.9.  It now uses libusb to
communicate with HP devices, and a side-effect of this is that it conflicts with
the kernel's usblp driver, which the CUPS 'usb' backend still uses.

Longer time, the CUPS 'usb' backend will be migrated to libusb as well, and
there will be no problem.

In the mean time there are two options:

1. Disable hplip.  Either remove the package or prevent the service from
starting using '/sbin/chkconfig hplip off', and stop the service with
'/sbin/service hplip stop' (or reboot).

2. Use the 'hp:/...' URI for that printer instead of 'usb:/...'.  Change this
using system-config-printer.

Note You need to log in before you can comment on or make changes to this bug.