Bug 192051 - gnome-keyboard-properties have "corrupted" gnome-settings-daemon which seems to effect bonobo
gnome-keyboard-properties have "corrupted" gnome-settings-daemon which seems ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: GConf2 (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-16 22:54 EDT by morgan read
Modified: 2008-03-18 14:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:34:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error window pic (24.72 KB, image/png)
2006-05-16 22:54 EDT, morgan read
no flags Details
Warning message pic (16.05 KB, image/png)
2006-05-16 23:09 EDT, morgan read
no flags Details

  None (edit)
Description morgan read 2006-05-16 22:54:52 EDT
Description of problem:
Please re-set component if incorrect: couldn't find gnome-keyboard-properties or
gnome-settings-daemon component to file under - may be bonobo too?

Gnome Keyboard Preference's configuration gui causes the Gnome Theme to cycle
between chosen theme and the default fc5 theme.  Also, the Keyboard Preferences'
Layout Options' "Alt/Win key behaviour" doesn't seem to be honoured (i.e. Supper
doesn't appear mapped to Win-keys as Window Preferences' Movement Key (Super)
isn't honoured).

Also, the Keyboard Preference's Typing Break has stoped working.  Keyboard
switching hasn't worked since install (between Maori and US).  And, Error
Messages (attached) have been appearing at logon as well as when Keyboard
Preference's gui is accessed.

Version-Release number of selected component (if applicable):
[morgan@morgansmachine ~]$ rpm -q gnome-session
gnome-session-2.14.1-1.fc5.1


How reproducible:
Always

Steps to Reproduce:
1.Open Desktop -> Preferences -> Keyboard
2.Screen starts cycleing between default and custom Theme & cpu goes to 100% (on
changing)
3.
  
Actual results:
Failure to save settngs; cycling between Themes; error pop-ups

Expected results:
Set Keyboard preferences

Additional info:
Comment 1 morgan read 2006-05-16 22:54:52 EDT
Created attachment 129294 [details]
Error window pic
Comment 2 morgan read 2006-05-16 23:09:52 EDT
Created attachment 129295 [details]
Warning message pic
Comment 3 Thomas J. Baker 2006-05-18 20:22:23 EDT
I'm experiencing similiar problems. It seems that preference caplets can't talk
to the gnome-settings-daemon even though it's running. Also some of my
preferences don't seem to be working like certain keyboard bindings. I haven't
really changed any preferences in quite a while and this is fairly new, within
the last week, so I don't necessarily believe any one preference is corrupted.
More like the gnome-sessions-daemon is locking up or something.
Comment 4 morgan read 2006-05-19 04:29:20 EDT
Changed component to gconfd-2.

version of gconfd-2 (which this may be better loged against?):
[morgan@morgansmachine ~]$ rpm -q GConf2
GConf2-2.14.0-1

I created a new login and moved everything across.  A work-around, and a lot of
work.

Comment 5 Ray Strode [halfline] 2008-03-18 14:34:14 EDT
Hi,

We no longer support Fedora Core 5 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.