Bug 1920583 - operator conditions storage
Summary: operator conditions storage
Keywords:
Status: CLOSED DUPLICATE of bug 1912945
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: aos-storage-staff@redhat.com
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-26 16:29 UTC by Parker Van Roy
Modified: 2021-01-27 15:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
operator conditions storage
Last Closed: 2021-01-27 11:28:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Parker Van Roy 2021-01-26 16:29:59 UTC
test:
operator conditions storage 

is failing frequently in CI, see search results:
https://search.ci.openshift.org/?maxAge=168h&context=1&type=bug%2Bjunit&name=&maxMatches=5&maxBytes=20971520&groupBy=job&search=operator+conditions+storage


https://testgrid.k8s.io/redhat-openshift-ocp-release-4.7-informing#periodic-ci-openshift-release-master-ocp-4.7-e2e-aws-proxy


operator conditions storage
Operator unavailable (null): operator is not reporting conditions

Comment 1 Jan Safranek 2021-01-27 11:28:35 UTC
> https://search.ci.openshift.org/?maxAge=168h&context=1&type=bug%2Bjunit&name=&maxMatches=5&maxBytes=20971520&groupBy=job&search=operator+conditions+storage

There is no storage specific failure, the cluster-storage-operator fails usually because of "Waiting for DaemonSet to deploy node pods", which means there is a node that is not healthy. Picking https://prow.ci.openshift.org/view/gs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-gcp-rt-4.7/1354308493313576960 as an example:

            "kind": "Node",
            "metadata": {
                "name": "ci-op-zthjrxz3-51060-htvsc-worker-d-xvwlh",
            },
            "spec": {
                "providerID": "gce://openshift-gce-devel-ci/us-east1-d/ci-op-zthjrxz3-51060-htvsc-worker-d-xvwlh",
                "taints": [
                    {
                        "effect": "NoSchedule",
                        "key": "node.kubernetes.io/unreachable",
                        "timeAdded": "2021-01-27T07:37:10Z"
                    },
                    {
                        "effect": "NoExecute",
                        "key": "node.kubernetes.io/unreachable",
                        "timeAdded": "2021-01-27T07:37:16Z"
                    }
                ]
            },

...
                "conditions": [
                    {
                        "lastHeartbeatTime": "2021-01-27T07:36:20Z",
                        "lastTransitionTime": "2021-01-27T07:37:10Z",
                        "message": "Kubelet stopped posting node status.",
                        "reason": "NodeStatusUnknown",
                        "status": "Unknown",
                        "type": "Ready"
                    }


> https://testgrid.k8s.io/redhat-openshift-ocp-release-4.7-informing#periodic-ci-openshift-release-master-ocp-4.7-e2e-aws-proxy

As you can see, it's getting more green on 01-21, when we fixed https://bugzilla.redhat.com/show_bug.cgi?id=1912945

*** This bug has been marked as a duplicate of bug 1912945 ***


Note You need to log in before you can comment on or make changes to this bug.