Bug 19206 - A reproducible installation failure of RedHat 7.0 anaconda when it tries mounting the SWAP partition.
A reproducible installation failure of RedHat 7.0 anaconda when it tries moun...
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-16 17:10 EDT by Eric Meek
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-16 17:11:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Dump file (978 bytes, text/plain)
2000-10-16 17:11 EDT, Eric Meek
no flags Details

  None (edit)
Description Eric Meek 2000-10-16 17:10:04 EDT
Every time I try to install Redhat 7.0 on my computer it crashes and dumps 
this text . . .

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + 
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//dos

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Here are the specs of my computer
MSI 649D Pro-A motherboard
a single 800EB PIII
128MBs of PC133 ECC memory
a 46gb Maxtor ATA/100 hard drive connected to the onboard UDMA 100 Promise 
controller
a Pioneer 10x Slot loading DVD drive connected to the ATA/66 controller
a Rendition Intense 3D 100 video card
a SBLive sound card
a Microsoft Internet Natural Keyboard and a Microsoft IntelliMouse.


With all the specs aside, here is exactly what happened when I started 
having problems with the Redhat installer.  

The first time I installed Redhat 7.0 I didn't have a problem except 
having to pass the IO address of the hard drive at the lilo prompt and 
booting of a floppy.  The reason, I was booting from a floppy was I wanted 
a dual booting system with Linux as the second partition behind a 13GB 
WIN32 partition.  I was going to install Kernel 2.17 once I got my system 
the way I wanted it, but before I could do that Linux died.  My computer 
and all it's components are just fine . . . but Linux is dead.  I had just 
about everything configured the way that I wanted it but the sound card.  
I went to configure the sound card using the sndconfig and that is where 
all my problems started.  

I forgot that I had an onboard sound card when I launched the utility and 
it chose that instead of my SBLive card.  Sndconfig choosing this card 
shouldn't have been much of a problem but I had disabled the onboard sound 
in the bios and wasn't watching what I was doing, always dangerous.  I 
proceeded to click through all of the options until I came to the test 
part when the utility hung.  I had no choice but to reboot and didn't 
think much of it until when Linux started up again it tried starting sound 
and then hung again.  So I again rebooted and tried going into the 
interactive startup, but that was all to no avail.  Seeing that I couldn't 
disablethe sound startup any other way, I decided to reinstall Linux.  
This option, however proved as futile as the last two and here is why.

Once I restarted with the Redhat 7.0 install CD 1 in the drive I proceeded 
to boot my normal way.  After booting, I ran anaconda, deleted the 
partitions, created new partitions and proceed until anaconda died when it 
was trying to mount the partitions right before it starts installing the 
selected RPMs.  I have tried everything, fdisk /mbr in DOS.  Deleting the 
partitions in DOS and creating a Extended DOS drive that takes the rest of 
the drive up and formatting it.  I have tried running E2FCSK at the bash 
prompt under the Linux cd but it won't run on /tmp/hde because it says 
that there is a invalid starting block.

I think that running e2fsck on the drives would fix my problem but I can't 
do it.  If anaconda automatically checked the drives before trying to 
mount then I believe this would solve my problem.  I would work on the 
problem myself, but my other school projects and programming assignments 
get priority.

If you have any other ideas about it let me know.  I really would like to 
get Linux up and running, but right now I havent had any success.

Thank you for your time,

Eric Meek
Comment 1 Eric Meek 2000-10-16 17:11:12 EDT
Created attachment 4228 [details]
Anaconda Dump file
Comment 2 Alan Cox 2000-10-16 19:42:35 EDT
RHBA-2000:084-02

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.