Bug 1920670 - [IPI baremetal] Keepalived - priority 0 advertisement message not being sent when the container is Sigtermed
Summary: [IPI baremetal] Keepalived - priority 0 advertisement message not being sent ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.8.0
Assignee: Yossi Boaron
QA Contact: Rei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-26 20:33 UTC by Yossi Boaron
Modified: 2021-08-16 18:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When Keepalived container that holds VIP being SIGTERMed no VRRP proactive message (priority 0 message) is sent Consequence: The VIP migrated to another after VRRP RX timeout Fix: When Keepalived container holds VIP being SIGTERMed a priority 0 VRRP advertisement message is sent. Result: Faster VIP migration in case Keepalived container that holds VIP being SIGTERMed
Clone Of:
Environment:
Last Closed: 2021-08-16 18:32:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 2367 0 None open Bug 1920670: [Baremetal and friends] Properly handle SIGTERM - Keepalived container 2021-01-31 16:10:45 UTC
Red Hat Product Errata RHBA-2021:3121 0 None None None 2021-08-16 18:32:28 UTC

Description Yossi Boaron 2021-01-26 20:33:24 UTC
Description of problem:

When Keepalived container that holds VIP being SIGTERMed (for example , as a result of 'virsh shutdown <node>' command in a virtual environment ) that should trigger a  priority 0 advertisement message  to allow faster VIP migration.

Running  'virsh shutdown <node>' command on a node holding VIP didn't trigger  VRRP priority 0 advertisement message

Version-Release number of selected component (if applicable):


How reproducible:

In dev-scripts environment
1. Check which node holds the VIP
2. run 'virsh shutdown <node> '

Steps to Reproduce:

See above

Actual results:
VIP moved to another node after timeout (3 * interval) 

Expected results:

1. Keepalived in shutdown node should send VRRP priority 0 advertisement message
2. Keepalived in one of the remaining master nodes should hold the VIP as soon as he receives the VRRP priority 0 message

Additional info:

Comment 7 errata-xmlrpc 2021-08-16 18:32:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.5 security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3121


Note You need to log in before you can comment on or make changes to this bug.