Bug 1920898 - [4.6.z]"500 Internal Error" for prometheus route in https_proxy cluster
Summary: [4.6.z]"500 Internal Error" for prometheus route in https_proxy cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.6.z
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.z
Assignee: Damien Grisonnet
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1933499 (view as bug list)
Depends On: 1926876
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-27 08:42 UTC by Junqi Zhao
Modified: 2021-04-12 04:51 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1920901 (view as bug list)
Environment:
Last Closed: 2021-03-30 17:03:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
prometheus UI (196.72 KB, image/png)
2021-03-22 02:47 UTC, Junqi Zhao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 1083 0 None open Bug 1920898: [4.6] pkg/manifests: fix prometheus-proxy trustedCA 2021-03-15 15:36:40 UTC
Red Hat Product Errata RHBA-2021:0952 0 None None None 2021-03-30 17:03:25 UTC

Comment 6 Damien Grisonnet 2021-03-01 13:41:59 UTC
*** Bug 1933499 has been marked as a duplicate of this bug. ***

Comment 9 Junqi Zhao 2021-03-22 02:46:34 UTC
tested with 4.6.0-0.nightly-2021-03-21-131139 https_proxy cluster, can login prometheus route correctly, no issue
# oc -n openshift-monitoring get pod prometheus-k8s-0 -oyaml
...
    name: prometheus
    ...
    volumeMounts:
    - mountPath: /etc/pki/ca-trust/extracted/pem/
      name: prometheus-trusted-ca-bundle
      readOnly: true
...
    name: prometheus-proxy
    ...
    volumeMounts:
    ...
    - mountPath: /etc/pki/ca-trust/extracted/pem/
      name: prometheus-trusted-ca-bundle
      readOnly: true

Comment 10 Junqi Zhao 2021-03-22 02:47:21 UTC
Created attachment 1765120 [details]
prometheus UI

Comment 13 errata-xmlrpc 2021-03-30 17:03:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.23 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0952


Note You need to log in before you can comment on or make changes to this bug.