Bug 1920970 - Lower dependency requirement on jack-audio-connection-kit to allow installation with pipewire
Summary: Lower dependency requirement on jack-audio-connection-kit to allow installati...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Carla
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: MartinKG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1934896 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-27 10:05 UTC by Olivier Samyn
Modified: 2021-03-12 20:30 UTC (History)
2 users (show)

Fixed In Version: Carla-2.2.0-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-11 07:56:42 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Olivier Samyn 2021-01-27 10:05:55 UTC
First, I'm aware of bug BZ#1911374 that has been closed as won't fix. 

But I think there is still a problem with current Carla packaging.

The current Carla package declares a strong dependency on jack-audio-connection-kit which in my opinion is wrong.

If I remove that requirement Carla is running perfectly fine with the pipewire provided jack connections. 
And in fact, the Carla package is even providing it's own libjack version, so I even think it should not depend on libjack to be installed.

As the package is functional without the jack-audio-connection-kit package being installed, and according to the weak dependencies policy, I think that the following line of Carla.spec:
	
Requires:       jack-audio-connection-kit

should either be dropped, or replaced by a simple:
Suggest:       jack-audio-connection-kit

Comment 1 Erich Eickmeyer 2021-03-04 00:08:14 UTC
*** Bug 1934896 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2021-03-05 14:50:58 UTC
FEDORA-2021-27cbc91efd has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-27cbc91efd

Comment 3 Fedora Update System 2021-03-05 18:57:18 UTC
FEDORA-2021-27cbc91efd has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-27cbc91efd`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-27cbc91efd

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2021-03-12 20:30:13 UTC
FEDORA-2021-27cbc91efd has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.