Bug 192101 - Sylpheed segfaults upon closing compose window with highlighted text
Summary: Sylpheed segfaults upon closing compose window with highlighted text
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-17 16:08 UTC by Paul Dickson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-08 20:05:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB backtrace of segfault (17.98 KB, text/plain)
2006-05-17 16:08 UTC, Paul Dickson
no flags Details

Description Paul Dickson 2006-05-17 16:08:38 UTC
Description of problem:
After composing message in sylpheed and pressing "send", the message is sent and
sylpheed segfaults when it attempts to close the compose window when there is
highlighted text in the message body.

Version-Release number of selected component (if applicable):
gtk2-2.9.1-1
glib2-2.11.1-1

How reproducible:
Always

Steps to Reproduce:
1. Start sylpheed and compose a message (or "sylpheed --compose")
2. Set To: and Subject:
3. Highlight some text in the message body.
4. Click "send".
  
Actual results:
Sylpheed segfaults.

Expected results:
Sylpheed continues to run.

Additional info:
I start this report with gtk2-2.9.0-4 and glib2-2.11.0-1 but while downloading
the debuginfo files I ended up with the new version.  The problem still exists
and the attached backtrace is for the new version.

An initial guess is because of the highlight text, there is some sort of
dangling reference.

Comment 1 Paul Dickson 2006-05-17 16:08:38 UTC
Created attachment 129335 [details]
GDB backtrace of segfault

Comment 2 Matthias Clasen 2006-09-08 20:05:15 UTC
fixed in 2.10.3-3


Note You need to log in before you can comment on or make changes to this bug.