Bug 192127 - LTC23882-FC5 swapon /dev/VolGroup00/LogVol01 failed after finished a fresh installation
LTC23882-FC5 swapon /dev/VolGroup00/LogVol01 failed after finished a fresh in...
Status: CLOSED DUPLICATE of bug 196179
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-17 15:31 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-28 11:16:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2006-05-17 15:31:01 EDT
LTC Owner is: thinh@us.ibm.com
LTC Originator is: liyuanly@cn.ibm.com


Problem description:
  We do a fresh installation FC5("fedora-development tree (aka rawhide),
snapshot May1") on machine plinuxt15. We can see a failed messages when it is
booting up:
Enabling swap space:  swapon: /dev/VolGroup00/LogVol01: Invalid argument
                                                                        [FAILED]

If this is a customer issue, please indicate the impact to the customer:


If this is not an installation problem,
       Describe any custom patches installed.

       Provide output from "uname -a", if possible:
Linux plinuxt15.cn.ibm.com 2.6.16-1.2181_FC6 #1 SMP Sun Apr 30 23:03:19 EDT 2006
ppc64 ppc64 ppc64 GNU/Linux

Hardware Environment
    Machine type (p650, x235, SF2, etc.): p650
    Cpu type (Power4, Power5, IA-64, etc.): Power4
    

Is this reproducible?
    If so, how long does it (did it) take to reproduce it?yes
    Describe the steps:
    1. Do fresh installation of FC5
    2. Select disk sda as installation target and accept default disk layout
    3. Finished the installation
    4. reboot it and view the boot messages



Additional information:
    1. After OS boot up, issue "top" and we can see the size of swap is zero:
Mem:   8079772k total,   127908k used,  7951864k free,     9060k buffers
Swap:        0k total,        0k used,        0k free,    46452k cached

I met similar problem on paytonlp1 which has / on swraid1

Disk partition info: I allocated 2G for swap (sda3)
[root@paytonlp1 ~]# fdisk -l | more

Disk /dev/sda: 73.4 GB, 73407488000 bytes
128 heads, 32 sectors/track, 35003 cylinders
Units = cylinders of 4096 * 512 = 2097152 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1           4        8176   41  PPC PReP Boot
/dev/sda2               5          54      102400   83  Linux
/dev/sda3           34004       35003     2048000   82  Linux swap / Solaris
/dev/sda4              55       34003    69527552    5  Extended
/dev/sda5              55       34003    69527536   fd  Linux raid autodetect

Partition table entries are not in disk order

Disk /dev/sdb: 73.4 GB, 73407488000 bytes
255 heads, 63 sectors/track, 8924 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1        8924    71681998+  fd  Linux raid autodetect


fstab
[root@paytonlp1 ~]# cat /etc/fstab
/dev/md0      /                       ext3    defaults        1 1
LABEL=/boot   /boot                   ext3    defaults        1 2
devpts        /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs         /dev/shm                tmpfs   defaults        0 0
proc          /proc                   proc    defaults        0 0
sysfs         /sys                    sysfs   defaults        0 0
LABEL=SWAP-sda3 swap                    swap    defaults        0 0
[root@paytonlp1 ~]#

display from "top"
[root@paytonlp1 ~]# top
top - 08:33:31 up  1:20,  1 user,  load average: 0.00, 0.00, 0.00
Tasks: 123 total,   1 running, 122 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.0% us,  0.1% sy,  0.0% ni, 99.8% id,  0.1% wa,  0.0% hi,  0.0% si,
Mem:   7681192k total,   142728k used,  7538464k free,    11768k buffers
Swap:        0k total,        0k used,        0k free,    44772k cached
Comment 1 IBM Bug Proxy 2006-06-06 03:32:14 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Version|FC5                         |devel




------- Additional Comments From liyuanly@cn.ibm.com  2006-06-06 03:34 EDT -------
I am changing the version to 'devel' to properly reflect that this recreates on
rawhide, snapshot May26. 
Comment 2 Phil Knirsch 2006-06-28 01:25:06 EDT
Reassigning to installer, as this is not a bug related to the filesystem component.

Read ya, Phil
Comment 3 Peter Jones 2006-06-28 11:16:41 EDT

*** This bug has been marked as a duplicate of 196179 ***
Comment 4 IBM Bug Proxy 2007-01-05 11:01:42 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|FIXEDAWAITINGTEST           |TESTED




------- Additional Comments From ed_pollard@us.ibm.com (prefers email at edpollar@linux.ibm.com)  2007-01-05 10:59 EDT -------
there has been no response to request to verify this bug for 4 months +/ closing
bug, if needed please re-open. 

Note You need to log in before you can comment on or make changes to this bug.