Bug 192133 - Changed user type string in APC 7921 v2.6.5
Summary: Changed user type string in APC 7921 v2.6.5
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: fence (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-17 20:09 UTC by Carsten Clasohm
Modified: 2009-04-16 20:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 14:39:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carsten Clasohm 2006-05-17 20:09:28 UTC
Description of problem:

The APC fencing agent in RHCS 3 does not work with a certain version of the APC
7921 Masterswitch, when the "device" account is used. It works with the "apc"
account, though.


Version-Release number of selected component (if applicable):
clumanager-1.2.31
APC 7921 version 2.6.5


How reproducible:
Always.


Steps to Reproduce:
1. Configure APC fencing for on of the cluster members, using the "device" account.
2. Run clufence -r <member>
3. clufence reports that fencing has failed.


Actual results:
Fencing only works with the "apc" account.


Expected results:
Fencing should work with the "device" account.


Additional info:
This is caused by a slight change in APC's telnet interface. With the version we
have, the user type is identified as "User : Device Manager", while apcmaster.c
looks for "User : Outlet User". The string for the "apc" account has remained
unchanged.

Adding support for this version of the APC 7921 should be easy, as UserType[] in
src/stonithlib/apcmaster.c already allows to specify multiple alternative strings.

Comment 1 Jim Parsons 2008-02-27 14:39:32 UTC
Adding support for additional user levels is a can of worms. It is tough enough
keeping this agent running through firmware revisions with the apc account. The
apc account must remain a requirement for now. 

As a work around, perhaps you could use the apc snmp agent?


Note You need to log in before you can comment on or make changes to this bug.