Bug 192148 - starting rgmanager without DLM loaded causes an infinite loop
Summary: starting rgmanager without DLM loaded causes an infinite loop
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: magma-plugins   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-17 21:28 UTC by Lon Hohberger
Modified: 2009-04-16 20:20 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007:0148
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 21:08:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes behavior (1.39 KB, text/x-patch)
2006-09-06 18:31 UTC, Lon Hohberger
no flags Details

Description Lon Hohberger 2006-05-17 21:28:23 UTC
Description of problem:

SSIA

Version-Release number of selected component (if applicable): 1.9.46

How reproducible: 100%

Steps to Reproduce:
1.  modprobe cman
2.  cman_tool join ...
3.  clurgmgrd
  
Actual results: infinite loop

Expected results: error / no start

Comment 1 Lon Hohberger 2006-09-06 18:31:06 UTC
Created attachment 135685 [details]
fixes behavior

Users of the SM plugin should not be allowed to start if the dlm isn't loaded. 


Patch adds a simple check for RHEL4 which checks for the existence of the
/dev/dlm-control device file upon startup.  This patch only applies to RHEL4 -
and should not be applied to the STABLE branch, since not all distributions
require/use udev.  For STABLE, this is a WONTFIX.

Comment 3 Lon Hohberger 2007-05-16 21:08:17 UTC
Cleanup


Note You need to log in before you can comment on or make changes to this bug.