This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 192156 - ytalk: useless debuginfo package
ytalk: useless debuginfo package
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ytalk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-17 18:45 EDT by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-20 00:51:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2006-05-17 18:45:47 EDT
$ rpm -qlp
http://fedoraproject.org/extras/development/i386/debug/ytalk-debuginfo-3.3.0-3.fc5.i386.rpm
(contains no files)

That's a useless debuginfo package, caused by explicit stripping of binaries. 
Fix: let rpmbuild do the stripping, use %makeinstall instead of
%makeinstall-strip (or even better, 'make install DESTDIR=$RPM_BUILD_ROOT' if it
works).
Comment 1 Mike McGrath 2006-05-20 00:51:10 EDT
I've made the change and it is currently in the build queue.
Comment 2 Ville Skyttä 2006-05-20 05:07:26 EDT
Judging from the commit messages, you seem to have forgotten that macros are
expanded in %changelog too.  They sometimes break packages when not escaped (by
doubling the '%' in them), and at least produce silly changelog entries for
example in rpm -q --changelog.
Comment 3 Mike McGrath 2006-05-20 21:43:43 EDT
I know better than that, It's fixed now.

Note You need to log in before you can comment on or make changes to this bug.