Bug 192162 - heavy iowait state
heavy iowait state
Status: CLOSED DUPLICATE of bug 192161
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-17 20:00 EDT by Richard
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 16:23:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard 2006-05-17 20:00:58 EDT
Description of problem:

We have a SUN/v20z(AMD64/x86). When heavy load IO activities done on local or
nfs disks (almost huge file copy), the kernel shows an abnormal IO's activity
with a state which reaches 100% and freezes totally all current processes. 

Version-Release number of selected component (if applicable):

RHEL3/WS - Linux katy 2.4.21-20.ELsmp #1 SMP Wed Aug 18 20:34:58 EDT 2004 x86_64
x86_64 x86_64 GNU/Linux

How reproducible:
Always

Steps to Reproduce:
1. 2 processes performing in parallel a "dd" read/write more than 1GB data with
bs=512 or bs=2M. test this on local disk and nfs disk.
2. while performing, check kernel activity by running a loop of 2s sleep and
check if the 2s sleep does really 2s or more!
2. after each dd i make a 'sync'
3. check out the iowait state, in average it reaches 98/99% and sometimes 100%
and freezes all current processes 
  
Actual results:
during the heavy io test with dd, the 2s sleep loop does sometimes more than 2s
sleep, it reaches 3s or 5s !! 

Expected results:
a 2s sleep should show 2s sleep even if the kernel is heavily loaded. our server
is running a semi-realtime system and we can't tolerate offset delay >100ms on a
sleep for instance...

Additional info:
Comment 1 Ernie Petrides 2006-05-18 16:23:25 EDT
This is apparently an accidental double bug entry.

*** This bug has been marked as a duplicate of 192161 ***

Note You need to log in before you can comment on or make changes to this bug.