Bug 192165 - Kernel does not boot after regular update
Kernel does not boot after regular update
Status: CLOSED DUPLICATE of bug 186842
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Alasdair Kergon
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-17 22:06 EDT by Joao Batista Gomes de Freitas
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-27 09:07:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joao Batista Gomes de Freitas 2006-05-17 22:06:26 EDT
Description of problem: After a regular update the kernel panics and hangs


Version-Release number of selected component (if applicable):
2.6.16-1.2096
2.6.16-1.2111
How reproducible:
It always happens with message /dev/mapper/nvidia_acaafeee invalid or something
similar and then it hangs stating that it can not mount any partitions

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
I am using a ASUS A8N-E motherboard with nvidia sata controller.
The RAID BIOS support is enabled
I am using LVM and hardware RAID 0 with 2 sata HDs
It doesn't happens with the original installed kernel (2.6.15-1.2054) only after
a regular update (yum update)
Comment 1 Joao Batista Gomes de Freitas 2006-05-22 19:40:43 EDT
I hoped that it would be fixed in new kernel release but it happened again in
version 2.6.16-1.2122.
This is what I see in my screen when I try to reboot:

Root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.16-1.2122_FC5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
[Linux-bzImage, setup=0x1e00, size=0x16e862]
initrd /initrd-2.6.16-1.2122_FC5.img
[Linux-initrd @ 0x37e3c000, 0x1b3698 bytes]

Uncompressing Linux... Ok, booting the kernel.
Red Hat nash version 5.0.32 starting
device-mapper: dm-stripe: Target length not divisible by chunk size
device-mapper: reload ioctl failed: Invalid argument

Unable to open /dev/mapper/nvidia_acaafeee – unrecognised disk label.
Reading all physical volumes. This may take a while...
No volume groups found
Unable to find volume group “VolGroup00”
Unable to access resume device (/dev/VolGroup00/LogVol01)
mount: could not find filesystem `/dev/root`
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic – not syncing: Attempted to kill init!
Comment 2 Joao Batista Gomes de Freitas 2006-05-26 18:27:28 EDT
After many tests I just  realize that the problem is related to kernel version
2.6.16-* and the nw implementation of sata_nv. Yesterday I installed a IDE disk
im my machine. Then I installed FC5 (version 2.6.15-1.2054) and updated to the
most recent kernel version. So now I have two VolumeGroups:
VolGroup00 : 2 Samsung s-ata 250G with RAID 0 enabled in the controller.
VolGroup01 : 1 IBM IDE 25 G 

FC5 is installed in both disks and 2 kernel version in each (2.6.15-1.2054 and
2.6.16-1.2122). So now when it boots the 2.6.15.-1.2054 version, I have no
problems it doesn't matter from wich disk I am booting. But when I use kernel
version 2.6.16-1.2122 it issues the same error related to VolGroup00 and the
only difference is that when I use IBM disk it boots anyway because it does not
need anything from VolGroup00. I have debug option turned on in the grub.conf
file and the error is the same : 
[CODE]device-mapper: dm-stripe: Target length not divisible by chunk size[/CODE]
Comment 3 Dave Jones 2006-05-27 00:26:58 EDT
the dm-stripe warning is likely the cause of this.
Alasdair, any ideas what changed in this area in 2.6.16 that could cause this?
Comment 4 Joao Batista Gomes de Freitas 2006-05-27 09:07:46 EDT

*** This bug has been marked as a duplicate of 186842 ***

Note You need to log in before you can comment on or make changes to this bug.