Bug 192172 - moving focus onto menubar with alt key
moving focus onto menubar with alt key
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-18 00:14 EDT by Akira TAGOH
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.0.3-1.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-19 13:48:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this patch might do what we want here (2.51 KB, patch)
2006-05-18 07:46 EDT, Caolan McNamara
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 65767 None None None Never

  None (edit)
Description Akira TAGOH 2006-05-18 00:14:18 EDT
Description of problem:
Focus is moved onto the menubar after pressing only alt key. it causes not
working of changing the input mode on scim-hangul, because it allows to change
it with tapping Alt_R that is similar behavior with Windows.

Version-Release number of selected component (if applicable):
2.0.3-0.169.3

How reproducible:
always

Steps to Reproduce:
1.install scim-hangul-0.2.2-3.fc6 and scim.
2. mkdir ~/.xinput.d && ln -s /etc/X11/xinit/xinput.d/scim ~/.xinput.d/default
(skip this step if scim is already running)
3. restart your desktop to make sure scim is running
4.run oowriter
5.press ctrl+space and change IM to hangul from the panel.
6.press alt_R
  
Actual results:
focus is moved onto menubar.

Expected results:
should change the input mode. if you have no changes in preference or never
running scim-hangul before, the input mode should be changed to the ascii mode
and the button on panel shouild displays "_A" then.

Additional info:
Comment 1 Caolan McNamara 2006-05-18 07:30:46 EDT
This looks like it might be related to some sort of "KEY_MENU" aliasing code
hanging off pressing Alt
Comment 2 Caolan McNamara 2006-05-18 07:46:50 EDT
Created attachment 129413 [details]
this patch might do what we want here
Comment 3 Caolan McNamara 2006-05-19 13:48:06 EDT
I've disabled this alt based KEY_MENU in 2.0.3-1.1, does that work correctly now ?
Comment 4 Akira TAGOH 2006-05-23 03:34:07 EDT
Yes, focus isn't moved onto menubar anymore. but tapping alt still doesn't work.
probably same issue at #192175. keep closing this bug then. thanks for quick fix.

Note You need to log in before you can comment on or make changes to this bug.