Bug 192183 - beagle-search crashes on search
beagle-search crashes on search
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-18 03:31 EDT by Joshua Wulf
Modified: 2014-10-19 18:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-21 05:47:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
beagle build patch for gtk# 2.9 (410 bytes, patch)
2006-06-06 14:08 EDT, Bart Vanbrabant
no flags Details | Diff

  None (edit)
Description Joshua Wulf 2006-05-18 03:31:00 EDT
Description of problem:
Beagle-search crashes on search

Version-Release number of selected component (if applicable):
beagle-0.2.6-2

How reproducible:
100%

Steps to Reproduce:
1. Invoke beagle-search via command line or from deskbar applet
2. Type in a search term
3. Hit search
  
Actual results:
Beagle search closes with no gtk error dialog

Expected results:
Search for files

Additional info:
Error output observed in terminal when launched from shell:

[jwulf@localhost ~]$ beagle-search

Unhandled Exception: System.InvalidCastException: Cannot cast from source type
to destination type.
in <0x0008c> Gtk.Widget:get_GdkWindow ()
in [0x00014] (at
/usr/src/build/742145-ppc/BUILD/beagle-0.2.6/search/Panes.cs:105)
Search.Panes+WhiteBox:OnExposeEvent (Gdk.EventExpose evt)
in <0x0009c> Gtk.Widget:exposeevent_cb (IntPtr widget, IntPtr evnt)
in (wrapper native-to-managed) Gtk.Widget:exposeevent_cb (intptr,intptr)
in <0x00000> <unknown method>
in (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0x0000c> Gtk.Application:Run ()
in <0x00010> Gnome.Program:Run ()
in [0x00076] (at
/usr/src/build/742145-ppc/BUILD/beagle-0.2.6/search/Search.cs:60)
Search.MainWindow:Main (System.String[] args)
Comment 1 darrell pfeifer 2006-05-28 12:00:18 EDT
The same problem occurs on x86 architecture.

It also occurs when attempting to run Tomboy notes applet.

I'm running a completely updated Rawhide system. The problem has occurred for
several weeks, I think since a Gtk update.
Comment 2 Bart Vanbrabant 2006-06-06 14:08:15 EDT
Patches in this bugreport should fix the gtk# part: #194262

Bealge will need a rebuild with the attached patch applied to resolve a
namespacing problem.
Comment 3 Bart Vanbrabant 2006-06-06 14:08:53 EDT
Created attachment 130626 [details]
beagle build patch for gtk# 2.9
Comment 4 Alexander Larsson 2006-06-21 05:47:44 EDT
Fixed in later version of gtk2.

Note You need to log in before you can comment on or make changes to this bug.