Bug 192187 - Install Guide
Install Guide
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: wiki (Show other bugs)
1.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Deon Ballard
ecs-bugs
: Documentation
Depends On:
Blocks: 152373 240316 FDS1.1.0
  Show dependency treegraph
 
Reported: 2006-05-18 04:54 EDT by Wayne Carruthers
Modified: 2012-06-21 19:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 19:15:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Wayne Carruthers 2006-05-18 04:54:04 EDT
Description of problem:

All the mistakes I made in my first eval of the install came about answering the
questions in the install script, The username pw entry screens tended to confuse
rather than be self explanatory, not sure of the solution

Pehaps a 1 or 2 line entry for each step

  
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rich Megginson 2006-05-18 10:01:27 EDT
Could you be more specific about individual screens/prompts and their wording?
Comment 2 Wayne Carruthers 2006-05-25 04:16:45 EDT
I finally had time to go back & do some uninstall & re installs on the test
system to define my problems better

My biggest problem it turns out was poor definition of dns, if an error occurs
in the installer script the admin scripts are not created & admin config files
not written so cant go back & manually correct them

Suggest better messages re cause of script failure & perhaps a pause on error to
allow correction of problem & then continue set up script

As for confusion, where the (name) is in the prompt I did not at first realise
it was the last entry I made, my fault, must have been a bit slow that day

Where the system user to run DS is suggested (nobody) & a non default name is
entered, then a prompt to create a valid system user external to the script or
auto creation of the non default user could be put into the script

One other observation, a mismatch in the name of the FC5 rpm to the software
actually installed made ininstall a little more complicated than normal

Anyway thanks & I think problems more me on that day than anything
Comment 4 Rich Megginson 2007-09-06 14:43:13 EDT
We should make sure the docs specify that DNS and reverse DNS must be working
correctly, especially if using TLS/SSL or Kerberos.

The RPM should create the user - this is the usual way service RPMs work.
Comment 5 Red Hat Bugzilla 2007-10-02 21:14:47 EDT
User bcleary@redhat.com's account has been closed
Comment 6 Deon Ballard 2007-10-11 20:46:18 EDT
Reassigning to me.
Comment 9 Deon Ballard 2007-10-31 00:27:23 EDT
There was alreayd a DNS/NIS section for Solaris; I used added this text to RHEL
and HPUX, then I added the above note about making sure DNS and reverse DNS is
working for TLS/SSL/Kerberos.

E.g.:
 It is very important that DNS and reverse DNS be working correctly on the host
machine, especially if you are using TLS/SSL or Kerberos with Directory Server.

Configure the DNS resolver and the NIS domain name by the modifying the
/etc/resolv.conf, /etc/nsswitch.conf, and /etc/netconfig files, and set the DNS
resolver for name resolution.

Edit the /etc/defaultdomain file to include the NIS domain name. This ensures
that the fully-qualified host and domain names used for the Directory Server
resolve to a valid IP address and that that IP address resolves back to the
correct hostname.

Reboot the Red Hat Enterprise Linux machine to apply these changes. 

http://engineering.redhat.com/docbot/en-US/RedHat_Directory_Server/8.0/html/Installation_Guide/Installation_Guide-Platform_RHEL-DNS.html
Comment 10 Deon Ballard 2011-05-19 14:43:28 EDT
Changing modifieds to ON_QA.
Comment 11 Andrew Ross 2011-05-19 17:42:23 EDT
Verified: Red_Hat_Directory_Server-Installation_Guide-8.0-web-en-US-8.0.5-5.el5

http://docs.redhat.com/docs/en-US/Red_Hat_Directory_Server/8.0/html/Installation_Guide/Installation_Guide-Support-Platforms.html#Installation_Guide-Platform_RHEL-DNS
Comment 12 Deon Ballard 2012-06-21 19:15:04 EDT
Closing.

Note You need to log in before you can comment on or make changes to this bug.