Bug 1921909 - Enable STS Support for Image Registry
Summary: Enable STS Support for Image Registry
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.7
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.7.0
Assignee: Joel Diaz
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-28 20:13 UTC by Scott Dodson
Modified: 2021-03-10 11:24 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-10 11:24:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-image-registry-operator pull 640 0 None closed Bug 1921909: build and use AWS config file for operator and operand 2021-02-15 10:46:26 UTC
Github openshift image-registry pull 257 0 None closed Bug 1921909: vendor in updated openshift/docker-distribution 2021-02-15 10:46:25 UTC
Red Hat Product Errata RHBA-2021:0678 0 None None None 2021-03-10 11:24:36 UTC

Description Scott Dodson 2021-01-28 20:13:27 UTC
STS work in 4.7 lacks Image Registry support, the linked PRs are outstanding and have previously been verified by CCO QE teams.

CCO and Image Registry QE teams should coordinate to make sure that both teams are familiar with the work.

Comment 20 Mike Fiedler 2021-02-16 03:08:13 UTC
Installed a cluster at version 4.7.0-0.nightly-2021-02-12-013204 following the instructions in comment 17 and registry pushes are working well.    I will trigger QE automation against this cluster, but I think we can mark this issue VERIFIED or CLOSED UPSTREAM.

Comment 21 Wenjing Zheng 2021-02-18 06:51:37 UTC
(In reply to Mike Fiedler from comment #20)
> Installed a cluster at version 4.7.0-0.nightly-2021-02-12-013204 following
> the instructions in comment 17 and registry pushes are working well.    I
> will trigger QE automation against this cluster, but I think we can mark
> this issue VERIFIED or CLOSED UPSTREAM.

Thanks for your follow up, Mike!
I also cannot reproduce this bug by triggering 10 builds on 4.7.0-rc.2 now:
$ oc get clusterversion
NAME      VERSION      AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.7.0-rc.2   True        False         3h1m    Cluster version is 4.7.0-rc.2
$ oc get builds
NAME                          TYPE     FROM          STATUS     STARTED          DURATION
rails-postgresql-example-5    Source   Git@9e6fe17   Complete   16 minutes ago   2m32s
rails-postgresql-example-6    Source   Git@9e6fe17   Complete   14 minutes ago   2m30s
rails-postgresql-example-7    Source   Git@9e6fe17   Complete   11 minutes ago   2m16s
rails-postgresql-example-8    Source   Git@9e6fe17   Complete   9 minutes ago    2m16s
rails-postgresql-example-9    Source   Git@9e6fe17   Complete   7 minutes ago    2m15s
rails-postgresql-example-10   Source   Git@9e6fe17   Complete   4 minutes ago    2m17s

Comment 24 errata-xmlrpc 2021-03-10 11:24:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.1 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0678


Note You need to log in before you can comment on or make changes to this bug.