Bug 192215 - AVM B1 PCI = Error inserting b1pci
Summary: AVM B1 PCI = Error inserting b1pci
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 5
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-18 13:40 UTC by Stefan Jensen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-09 10:53:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stefan Jensen 2006-05-18 13:40:03 UTC
Description of problem:

i want to load the Kernelmodule 'b1pci.ko' which comes with the
FC5 Kernel '2.6.16-1.2111_FC5smp' for use with my AVM B1 ISDN Card,
but the kernelmodules won't load.

#lspci
[...]
02:0d.0 Network controller: AVM Audiovisuelles MKTG & Computer System GmbH B1
ISDN (rev 01)
[...] 

When i load the module into the kernel, i got:

# modprobe b1pci
#
WARNING: Error inserting b1dma
(/lib/modules/2.6.16-1.2111_FC5smp/kernel/drivers/isdn/hardware/avm/b1dma.ko):
Invalid argument
FATAL: Error inserting b1pci
(/lib/modules/2.6.16-1.2111_FC5smp/kernel/drivers/isdn/hardware/avm/b1pci.ko):
Unknown symbol in module, or unknown parameter (see dmesg)

after that, only the following modules are loaded:

#lsmod| grep b1
b1 28365 0
kernelcapi 49089 1 b1

output of dmesg:
# dmesg
[...]
b1dma: falsely claims to have parameter suppress_pollack
b1pci: Unknown symbol b1dma_send_message
b1pci: Unknown symbol b1pciv4_detect
b1pci: Unknown symbol b1dma_interrupt
b1pci: Unknown symbol b1dma_register_appl
b1pci: Unknown symbol b1dma_reset_ctr
b1pci: Unknown symbol b1dma_release_appl
b1pci: Unknown symbol b1dma_reset
b1pci: Unknown symbol b1dma_load_firmware
b1pci: Unknown symbol b1dmactl_read_proc 

How reproducible:

install a AVM B1 Card,
boot to kernel 2.6.16-1.XXX and load the kernelmodule.
(this error happend to all kernelversion i've try since FC5 official release)

Rebuilding modules doesn't help, same result.
(build with current .config)
  
Actual results:

kernel module not loaded, card not functional

Expected results:

kernel modules loaded, card ready for configuration.


Note You need to log in before you can comment on or make changes to this bug.