Bug 192242 - device-mapper-multipath fails to build in mock
Summary: device-mapper-multipath fails to build in mock
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: device-mapper-multipath   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: BuildReqBlocker
TreeView+ depends on / blocked
 
Reported: 2006-05-18 15:45 UTC by Brian Pepple
Modified: 2013-01-10 03:43 UTC (History)
10 users (show)

Fixed In Version: 0.4.7-1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-19 21:46:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Failed Mock build log (7.61 KB, text/plain)
2006-05-18 15:45 UTC, Brian Pepple
no flags Details

Description Brian Pepple 2006-05-18 15:45:32 UTC
This package fails to build in mock.  build.log is attached.

Comment 1 Brian Pepple 2006-05-18 15:45:32 UTC
Created attachment 129444 [details]
Failed Mock build log

Comment 2 Brian Pepple 2006-05-18 16:11:02 UTC
device-mapper-mulitpath needs BR for libsepol-devel & readline-devel, but it
still fails in mock since it's missing the following header: linux/unistd.h.

What's the best way to satisfy the requirement?

Comment 3 Alasdair Kergon 2006-05-22 14:22:32 UTC
The code needs fixing - shouldn't be necessary to use _syscall5 any more.
lvm2 used to have that (workaround for outdated header files), but was able to
remove it a long time ago.

Should have
#define _FILE_OFFSET_BITS 64


Comment 4 Alasdair Kergon 2006-05-22 14:24:09 UTC
Does it also need these two BuildRequires or not?

  libtermcap-devel, ncurses-devel


Comment 5 Alasdair Kergon 2006-05-22 14:27:16 UTC
Added BuildRequires: libsepol-devel, readline-devel

Comment 6 Ben Marzinski 2006-05-24 20:03:53 UTC
The <linux/unistd.h> requirement has been removed in
device-mapper-multipath-0.4.5-17.0

let me know if this fixes all the problems.

Comment 7 Matt Domsch 2006-06-19 21:46:10 UTC
device-mapper-multipath-0.4.7-1.0.src.rpm builds on i386 and x86_64.


Note You need to log in before you can comment on or make changes to this bug.