Bug 1922533 - Many international google-noto-*-fonts have invalid Appstream data
Summary: Many international google-noto-*-fonts have invalid Appstream data
Keywords:
Status: CLOSED DUPLICATE of bug 1830709
Alias: None
Product: Fedora
Classification: Fedora
Component: google-noto-fonts
Version: 33
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-30 01:48 UTC by hank.johnson3002
Modified: 2021-04-05 07:29 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-05 07:29:02 UTC
Type: Bug


Attachments (Terms of Use)
List of google-noto-*-fonts packages with Appstream data issues (5.83 KB, text/plain)
2021-01-30 01:48 UTC, hank.johnson3002
no flags Details
Example `appstreamcli status --verbose` with invalid font Appstream data (94.14 KB, text/plain)
2021-01-30 01:52 UTC, hank.johnson3002
no flags Details

Description hank.johnson3002 2021-01-30 01:48:53 UTC
Created attachment 1752196 [details]
List of google-noto-*-fonts packages with Appstream data issues

Description of problem:

Many international google-noto-*-fonts have invalid Appstream data. This causes warnings in applications using Appstream, like KDE Discover. It also makes many appstreamcli commands not work.

Version-Release number of selected component (if applicable):

Most of them are version 20181223-8.fc33

How reproducible:

Should be easy

Steps to Reproduce:

1. sudo dnf install google-noto-sans-arabic fonts (I will attach a txt file with the full list of google-noto fonts with this issue)

Actual results:

Running `appstreamcli status` warns "Error while loading the metadata pool: Many components have been recognized as invalid. See debug output for details." Verbose output with `appstreamcli status --verbose` is attached in txt file.

Opening KDE Discover creates a warning that "Please make sure that Appstream is properly set up on your system".

Expected results:

Running `appstreamcli status` reports no errors. Opening KDE Discover shows no warning.

Additional info:

Removing the specified fonts fixes the issues. I tried force refreshing appstream cache, rebooting, reinstalling appstream data, etc.

TXT file with list of the violating fonts is attached.

Comment 1 hank.johnson3002 2021-01-30 01:52:44 UTC
Created attachment 1752197 [details]
Example `appstreamcli status --verbose` with invalid font Appstream data

Comment 2 Akira TAGOH 2021-04-05 07:29:02 UTC

*** This bug has been marked as a duplicate of bug 1830709 ***


Note You need to log in before you can comment on or make changes to this bug.