Bug 192281 - xend update breaks xen
Summary: xend update breaks xen
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xen   
(Show other bugs)
Version: 5
Hardware: i686
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Xen Maintainance List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-18 19:02 UTC by Michael Richardson
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 21:03:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file of starting xend (12.17 KB, text/plain)
2006-05-18 19:02 UTC, Michael Richardson
no flags Details
xend debug log (53 bytes, text/plain)
2006-05-18 19:04 UTC, Michael Richardson
no flags Details
strace -ff -o /tmp/xend$$ /usr/sbin/xend start, output. (one file) (5.98 KB, text/plain)
2006-05-18 19:33 UTC, Michael Richardson
no flags Details
strace -ff file, (this is the right one) (8.61 KB, text/plain)
2006-05-18 19:35 UTC, Michael Richardson
no flags Details

Description Michael Richardson 2006-05-18 19:02:23 UTC
Description of problem:

A newly installed FC5 system, having run yum update, fails to be able to start
xend. The xend.log is attached.

Version-Release number of selected component (if applicable):

bronwen-[~] root 14 #rpm -qf /usr/sbin/xend
xen-3.0.1-4

bronwen-[~] root 15 #rpm -qf /boot/vmlinuz-2.6.16-1.2111_FC5xen0
kernel-xen0-2.6.16-1.2111_FC5

How reproducible:

First system (trout) was upgraded from FC5test2, and had this problem.
A second system had just been installed from final CD, and it failed as well.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

(maybe Xend is not compatible with kernel?)

An strace of xend showed it trying to start /usr/sbin/xenstored, and failing
because /proc/xen/xsd_kva does not exist.
bronwen-[~] root 18 #ls /proc/xen
balloon  capabilities  privcmd  xenbus  xsd_kva  xsd_port

maybe something isn't loaded that needs to be?

Comment 1 Michael Richardson 2006-05-18 19:02:23 UTC
Created attachment 129476 [details]
log file of starting xend

Comment 2 Michael Richardson 2006-05-18 19:04:12 UTC
Created attachment 129477 [details]
xend debug log

Comment 3 Michael Richardson 2006-05-18 19:10:19 UTC
uhm, not /proc/xen/xsd_kva exists on machine bronwen.
It does not on machine trout:

trout-[/etc] root 52 #ls /proc/xen
balloon  capabilities  privcmd  xenbus  xsd_mfn  xsd_port

trout-[/etc] root 53 #uname -a
Linux trout.sandelman.ca 2.6.15-1.1977_FC5hypervisor #1 SMP Thu Feb 23 15:27:47
EST 2006 i686 athlon i386 GNU/Linux


Comment 4 Brian Stein 2006-05-18 19:14:52 UTC
Can you reproduce this with 2118_FC5 from updates-testing or does this fix it?

Comment 5 Michael Richardson 2006-05-18 19:33:52 UTC
Created attachment 129479 [details]
strace -ff -o /tmp/xend$$ /usr/sbin/xend start, output. (one file)

Comment 6 Michael Richardson 2006-05-18 19:35:34 UTC
Created attachment 129480 [details]
strace -ff file, (this is the right one)

Comment 7 Michael Richardson 2006-05-18 20:19:55 UTC
Yes, 2118_FC5 seems to solve the problem.
THANK YOU.



Note You need to log in before you can comment on or make changes to this bug.