This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 192289 - LTC23880-Graphics desktop failed to display when network installing with VNC
LTC23880-Graphics desktop failed to display when network installing with VNC
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
6
ppc64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Adam Tkac
David Lawrence
: Reopened
: 175458 (view as bug list)
Depends On:
Blocks: FC6Target FC7Blocker 209308
  Show dependency treegraph
 
Reported: 2006-05-18 15:41 EDT by IBM Bug Proxy
Modified: 2013-04-30 19:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.1.2-15.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-06 13:55:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2006-05-18 15:41:22 EDT
Problem description:
I was testing "fedora-development tree (aka rawhide), snapshot May1" on 
Power4 system plinuxt8.
I did VNC-display install using network boot image, anaconda was successfully
loaded and the VNC server is showing "running".
I was able to connect to plinuxt8.cn.ibm.com:1 using VNC Viewer, but it
displayed nothing but "big black screen".

If this is not an installation problem,
       Describe any custom patches installed.

       Provide output from "uname -a", if possible:
sh-3.1# uname -a
Linux localhost.localdomain 2.6.16-1.2181_FC6 #1 SMP Sun Apr 30 23:03:19 EDT
2006 ppc64 unknown

Hardware Environment
    p630:Power4

1) ensure /etc/bootptab on server points to correct inst64 network boot image
2) ensure bootlist has the network device as first  
3) exit to OpenFirmware prompt with 1st boot device = network to start tftpboot
add "boot vnc vncpassword=<password>" at OF prompt.
4) after anaconda started, you will be asked to connect to vnc-display desktop.
5) using vnc viewer to connect...You will meet the defect.


Additional information:
Output from the vterm:
"Running anaconda, the Fedora Core system installer - please wait...
Framebuffer ioctl failed. Exiting.
Probing for video card:   Unable to probe
Probing for monitor type:   Unknown monitor
No video hardware found, assuming headless
Starting VNC...
The VNC server is now running.
Please connect to plinuxt8.cn.ibm.com:1 to begin the install...
Starting graphical installation...

"

sh-3.1# ps -ef
UID        PID  PPID  C STIME TTY          TIME CMD
root         1     0  0 May15 hvc0     00:00:04 /init vnc
root         2     1  0 May15 ?        00:00:00 [migration/0]
root         3     1  0 May15 ?        00:00:00 [ksoftirqd/0]
root         4     1  0 May15 ?        00:00:00 [watchdog/0]
root         5     1  0 May15 ?        00:00:00 [migration/1]
root         6     1  0 May15 ?        00:00:00 [ksoftirqd/1]
root         7     1  0 May15 ?        00:00:00 [watchdog/1]
root         8     1  0 May15 ?        00:00:03 [events/0]
root         9     1  0 May15 ?        00:00:02 [events/1]
root        10     1  0 May15 ?        00:00:00 [khelper]
root        11     1  0 May15 ?        00:00:00 [kthread]
root        35    11  0 May15 ?        00:00:00 [kblockd/0]
root        36    11  0 May15 ?        00:00:00 [kblockd/1]
root        40    11  0 May15 ?        00:00:00 [khubd]
root        42    11  0 May15 ?        00:00:00 [kseriod]
root        60     1  0 May15 ?        00:00:03 [rtasd]
root        94    11  0 May15 ?        00:00:00 [pdflush]
root        95    11  0 May15 ?        00:00:00 [pdflush]
root        96     1  0 May15 ?        00:00:00 [kswapd0]
root        97    11  0 May15 ?        00:00:00 [aio/0]
root        98    11  0 May15 ?        00:00:00 [aio/1]
root       169    11  0 May15 ?        00:09:31 [khvcd]
root       252    11  0 May15 ?        00:00:00 [kpsmoused]
root       258     1  0 May15 hvc0     00:00:00 /init vnc
root       259     1  0 May15 hvc0     00:00:07 /sbin/loader --virtpconsole
/dev/hvc0
root       363    11  0 May15 ?        00:00:00 [scsi_eh_0]
root       413    11  0 May15 ?        00:00:00 [scsi_eh_1]
root       446    11  0 May15 ?        00:00:00 [scsi_eh_2]
root       479    11  0 May15 ?        00:00:00 [rpciod/0]
root       480    11  0 May15 ?        00:00:00 [rpciod/1]
root       481     1  0 May15 ?        00:00:00 [loop0]
root       514   259  0 May15 tty2     00:00:00 -/bin/sh
root       567    11  0 May15 ?        00:00:00 [jfsIO]
root       568    11  0 May15 ?        00:00:00 [jfsCommit]
root       569    11  0 May15 ?        00:00:00 [jfsCommit]
root       570    11  0 May15 ?        00:00:00 [jfsSync]
root       576    11  0 May15 ?        00:00:00 [xfslogd/0]
root       577    11  0 May15 ?        00:00:00 [xfslogd/1]
root       578    11  0 May15 ?        00:00:00 [xfsdatad/0]
root       579    11  0 May15 ?        00:00:00 [xfsdatad/1]
root       596    11  0 May15 ?        00:00:00 [kmirrord]
root       604   259 99 May15 hvc0     2-17:01:33 /usr/bin/python
/usr/bin/anaconda -m nfs://mnt/source/. --vnc --graphical --selinux
--virtpconsole /dev/hvc0 --lang en_US.UTF-8
root       623   604  0 May15 hvc0     00:00:00 //usr/bin/Xvnc :1 -nevershared
-depth 16 -geometry 800x600 IdleTimeout=0 -auth /dev/null -once
DisconnectClients=false desktop=Fedora Core 5.90 installation on host
plinuxt8.cn.ibm.com -rfbauth /tmp/vncpasswd_file
root       625   604  0 May15 hvc0     00:00:00 //usr/bin/mini-wm --display :1
root       628   604  0 May15 hvc0     00:00:00 /usr/bin/python
/usr/bin/anaconda -m nfs://mnt/source/. --vnc --graphical --selinux
--virtpconsole /dev/hvc0 --lang en_US.UTF-8
root       637   628  0 May15 hvc0     00:00:00 /bin/sh
root       662   637  0 20:36 hvc0     00:00:00 ps -ef

sh-3.1# cat /tmp/anaconda.log
...........
03:25:14 INFO    : inserted /tmp/dm-snapshot.ko
03:25:14 INFO    : load module set done
03:25:14 INFO    : NFS install method detected, will use RHupdates/
03:25:14 INFO    : Running anaconda script /usr/bin/anaconda
03:25:14 DEBUG   : adding extraArg --vnc
03:25:18 INFO    : Display mode = g
03:25:18 INFO    : Method = nfs://mnt/source/.
03:25:18 INFO    : _Fedora is only installclass, using it
03:25:28 INFO    : No video hardware found, assuming headless
03:25:32 INFO    : Starting VNC...
03:25:33 INFO    : The VNC server is now running.
03:25:33 INFO    : Please connect to plinuxt8.cn.ibm.com:1 to begin the install...
03:25:35 INFO    : Started mini-wm
03:25:35 INFO    : Starting graphical installation...
03:25:38 INFO    : anaconda floppy device is fd0
sh-3.1#
Comment 1 IBM Bug Proxy 2006-06-06 01:17:19 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Version|FC5                         |devel




------- Additional Comments From liyuanly@cn.ibm.com  2006-06-06 01:22 EDT -------
I am changing the version to 'devel' to properly reflect that this recreates on
rawhide.
The status of this bug is updated; I tried to recreate on the May26 snapshot of
rawhide, but it was blocked by #24198. 
Comment 2 Phil Knirsch 2006-06-28 00:35:11 EDT
Reassigning to proper component as this either looks like an installer and/or
kernel issue.

Read ya, Phil
Comment 3 IBM Bug Proxy 2006-08-31 22:01:12 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
              Owner|thinh@us.ibm.com            |kumarr@us.ibm.com
          QAContact|thinh@us.ibm.com            |kumarr@us.ibm.com




------- Additional Comments From chavez@us.ibm.com (prefers email at lnx1138@us.ibm.com)  2006-08-31 21:57 EDT -------
Yuan,

Any idea if this problem occuring with latest FC tree?

RH,

Any update?

thanks. 
Comment 4 IBM Bug Proxy 2006-09-13 12:16:40 EDT
------- Additional Comments From kumarr@us.ibm.com (prefers email at kumarr@linux.ibm.com)  2006-09-13 12:14 EDT -------
(In reply to comment #9)
> Yuan,
> 
> Any idea if this problem occuring with latest FC tree?
> 
> RH,
> 
> Any update?
> 
> thanks.

Yuan, Can you please let us know the results of your tests uisng the latest FC
release?

Thanks 
Comment 5 IBM Bug Proxy 2006-09-14 05:01:06 EDT
------- Additional Comments From liyuanly@cn.ibm.com  2006-09-14 04:56 EDT -------
(In reply to comment #10)
> (In reply to comment #9)
> > Yuan,
> > 
> > Any idea if this problem occuring with latest FC tree?
> > 
> > RH,
> > 
> > Any update?
> > 
> > thanks.
> 
> Yuan, Can you please let us know the results of your tests uisng the latest FC
> release?
> 
> Thanks
> 
Sorry, we are no longer testing FC releases. Anyway,  I will get the install
source and verify on my system. I will let you know the result ASAP. 
Comment 6 IBM Bug Proxy 2006-09-14 05:26:30 EDT
----- Additional Comments From liyuanly@cn.ibm.com  2006-09-14 05:21 EDT -------
The bug 26504 RH204404 - can not configure network card IP while Network
installtion on RC6 blocked my testing.
https://bugzilla.linux.ibm.com/show_bug.cgi?id=26504 
Comment 7 IBM Bug Proxy 2006-09-25 11:44:29 EDT
----- Additional Comments From liyuanly@cn.ibm.com  2006-09-25 06:14 EDT -------
Tested with fc6-test3 on the same machine.
I could see the graphic interface with vncviewer. After I confirmed "Install
anyway" and clicked "Next". It goes into xmon.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Running anaconda, the Fedora Core system installer - please wait...
Probing for video card:   Unable to probe
No video hardware found, assuming headless
Starting VNC...


WARNING!!! VNC server running with NO PASSWORD!
You can use the vncpassword=<password> boot option
if you would like to secure the server.


The VNC server is now running.
Please connect to 9.181.140.36:1 to begin the install...

Starting graphical installation...

Press <enter> for a shell
XKB extension not present on :1
cpu 0x1: Vector: 700 (Program Check) at [c000000004cd3690]
    pc: c0000000000ff7b8: .shrink_dcache_for_umount_subtree+0x204/0x304
    lr: c0000000000ff7b4: .shrink_dcache_for_umount_subtree+0x200/0x304
    sp: c000000004cd3910
   msr: 8000000000029032
  current = 0xc0000001bfd35ca0
  paca    = 0xc000000000494580
    pid   = 1122, comm = anaconda
kernel BUG in shrink_dcache_for_umount_subtree at fs/dcache.c:615!
enter ? for help
1:mon>
0:mon> t
[c00000003fc679a0] c0000000001005d4 .shrink_dcache_for_umount+0x50/0x74
[c00000003fc67a20] c0000000000e8878 .generic_shutdown_super+0x3c/0x1b0
[c00000003fc67ab0] c0000000000e8a1c .kill_block_super+0x30/0x60
[c00000003fc67b40] c0000000000e8bd8 .deactivate_super+0xd4/0x128
[c00000003fc67bd0] c000000000105d2c .mntput_no_expire+0x84/0x10c
[c00000003fc67c60] c0000000000f1828 .path_release_on_umount+0x30/0x48
[c00000003fc67cf0] c000000000106984 .sys_umount+0x300/0x36c
[c00000003fc67e30] c00000000000871c syscall_exit+0x0/0x40
--- Exception: c01 (System Call) at 000000000fc0bf38
SP (fd4cdcd0) is in userspace
0:mon>
0:mon> r
R00 = c0000000000ff7b4   R16 = 00000000f7b52d00
R01 = c00000003fc67910   R17 = 00000000f7b59260
R02 = c0000000005b2b20   R18 = 0000000000000000
R03 = 0000000000000062   R19 = 00000000100201b8
R04 = 8000000000001032   R20 = 0000000000000000
R05 = 0000000000000000   R21 = 00000000f7b5b0ad
R06 = 0000000000000000   R22 = 000000001008e848
R07 = 0000000000000000   R23 = 000000001008e9a0
R08 = c00000000463c9b0   R24 = 000000000fed41b0
R09 = c000000000650000   R25 = 0000000000000000
R10 = 0000000000000008   R26 = 000000001008e848
R11 = 0000000000000000   R27 = 0000000000000000
R12 = 000000000000000a   R28 = c00000000f8d32d0
R13 = c000000000494380   R29 = c0000001b5064c28
R14 = 00000000ffffffff   R30 = c0000000004e8008
R15 = 00000000f7b5b034   R31 = c0000001b5060b28
pc  = c0000000000ff7b8 .shrink_dcache_for_umount_subtree+0x204/0x304
lr  = c0000000000ff7b4 .shrink_dcache_for_umount_subtree+0x200/0x304
msr = 8000000000029032   cr  = 24228882
ctr = c00000000005aae4   xer = 0000000000000000   trap =  700
0:mon>
0:mon> di c0000000000ff7b8
c0000000000ff7b8  0fe00000      twi     31,r0,0
c0000000000ff7bc  ebfd0038      ld      r31,56(r29)
c0000000000ff7c0  7fbfe800      cmpd    cr7,r31,r29
c0000000000ff7c4  409e000c      bne     cr7,c0000000000ff7d0    #
.shrink_dcache_for_umount_subtree+0x21c/0x304
c0000000000ff7c8  3be00000      li      r31,0
c0000000000ff7cc  48000014      b       c0000000000ff7e0        #
.shrink_dcache_for_umount_subtree+0x22c/0x304
c0000000000ff7d0  7c00f828      lwarx   r0,r0,r31
c0000000000ff7d4  3000ffff      addic   r0,r0,-1
c0000000000ff7d8  7c00f92d      stwcx.  r0,r0,r31
c0000000000ff7dc  40a2fff4      bne     c0000000000ff7d0        #
.shrink_dcache_for_umount_subtree+0x21c/0x304
c0000000000ff7e0  387d0060      addi    r3,r29,96
c0000000000ff7e4  480ac40d      bl      c0000000001abbf0        # .list_del+0x0/0xb0
c0000000000ff7e8  60000000      nop
c0000000000ff7ec  e93e8000      ld      r9,-32768(r30)
c0000000000ff7f0  81690000      lwz     r11,0(r9)
c0000000000ff7f4  396bffff      addi    r11,r11,-1
0:mon> 
Comment 8 Adam Tkac 2006-10-20 08:31:32 EDT
Please, see bug #175458. I think, this bugs are same...
Comment 9 IBM Bug Proxy 2006-10-20 11:06:17 EDT
----- Additional Comments From kumarr@us.ibm.com (prefers email at kumarr@linux.ibm.com)  2006-10-20 11:04 EDT -------
Hello Redhat, Yes -- These bugs are the same. We have closed this bug from the
IBM side as we were unable to recreate the problem in more recent releases of
the FC tree. 
Comment 10 Adam Tkac 2006-10-24 04:16:35 EDT
*** Bug 175458 has been marked as a duplicate of this bug. ***
Comment 11 IBM Bug Proxy 2006-11-16 20:50:45 EST
----- Additional Comments From chavez@us.ibm.com (prefers email at lnx1138@us.ibm.com)  2006-11-16 20:48 EDT -------
I hate to ask you again Lin but are we still seeing this with Beta2 (Nov11
release) ? 
Comment 12 IBM Bug Proxy 2006-11-17 01:15:44 EST
----- Additional Comments From shenlinf@cn.ibm.com  2006-11-17 01:10 EDT -------
yes :( 
Comment 13 Fedora Update System 2006-11-28 12:16:35 EST
vnc-4.1.2-7.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 14 IBM Bug Proxy 2006-12-07 04:06:00 EST
----- Additional Comments From shenlinf@cn.ibm.com  2006-12-07 04:00 EDT -------
The problem is fixed in RHEL5 RC snap shot 2. Please change the status. Thanks. 
Comment 15 IBM Bug Proxy 2006-12-07 08:06:03 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ASSIGNED                    |FIXEDAWAITINGTEST
         Resolution|                            |FIX_BY_DISTRO
   Target Milestone|---                         |RHEL5_Beta2




------- Additional Comments From sglass@us.ibm.com  2006-12-07 08:04 EDT -------
Setting this to Closed based on the last comment. 
Comment 16 David Woodhouse 2007-03-06 10:15:38 EST
The problem seems to have returned in F7t2.
http://david.woodhou.se/badvnc.jpeg
Comment 17 David Woodhouse 2007-03-06 11:37:29 EST
Adding '-render' to Xvnc arguments doesn't help.
Comment 18 Adam Tkac 2007-03-06 11:41:22 EST
(In reply to comment #17)

This regression started in vnc-*4.1.2-12.fc7 and ended in vnc-*4.1.2-15.fc7 (I
think). It is caused by bad pixmap initialization. Could you give me access to
test ppc64? I want test vnc-server-4.1.2-15.fc7 if this issue is solved there (I
tested it on x86_64 and problem looks fixed)

Regards, Adam
Comment 19 Adam Tkac 2007-03-06 13:55:57 EST
Fixed in 4.1.2-15.fc7

Note You need to log in before you can comment on or make changes to this bug.