Bug 1922975 - python-envisage fails to build with Python 3.10: multiple different test failures
Summary: python-envisage fails to build with Python 3.10: multiple different test fail...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: python-envisage
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1968967 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-02-01 08:43 UTC by Tomáš Hrnčiar
Modified: 2021-08-03 10:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-03 10:44:03 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github enthought envisage issues 396 0 None open Need test eggs for python 3.10 2021-02-02 04:36:34 UTC

Description Tomáš Hrnčiar 2021-02-01 08:43:38 UTC
python-envisage fails to build with Python 3.10.0a4.

======================================================================
ERROR: exclude specific
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/envisage-5.0.0/envisage/tests/test_egg_plugin_manager.py", line 97, in test_exclude_specific
    self._add_eggs_on_path([self.egg_dir])
  File "/builddir/build/BUILD/envisage-5.0.0/envisage/tests/test_egg_based.py", line 59, in _add_eggs_on_path
    raise SystemError("Cannot find eggs %s" % errors)
SystemError: Cannot find eggs {}

======================================================================
FAIL: test_find_plugins_in_eggs_on_the_plugin_path (envisage.tests.test_egg_basket_plugin_manager.EggBasketPluginManagerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/envisage-5.0.0/envisage/tests/test_egg_basket_plugin_manager.py", line 56, in test_find_plugins_in_eggs_on_the_plugin_path
    self.assertEqual(len(ids), 3)
AssertionError: 0 != 3
-------------------- >> begin captured logging << --------------------
envisage.egg_basket_plugin_manager: DEBUG: egg basket plugin manager found plugins <[]>
--------------------- >> end captured logging << ---------------------

======================================================================
FAIL: test_ignore_broken_distributions_raises_exceptions_by_default (envisage.tests.test_egg_basket_plugin_manager.EggBasketPluginManagerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/envisage-5.0.0/envisage/tests/test_egg_basket_plugin_manager.py", line 184, in test_ignore_broken_distributions_raises_exceptions_by_default
    iter(plugin_manager)
AssertionError: SystemError not raised
-------------------- >> begin captured logging << --------------------
envisage.egg_basket_plugin_manager: DEBUG: egg basket plugin manager found plugins <[]>
--------------------- >> end captured logging << ---------------------

======================================================================
FAIL: test_ignore_broken_plugins_raises_exceptions_by_default (envisage.tests.test_egg_basket_plugin_manager.EggBasketPluginManagerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/envisage-5.0.0/envisage/tests/test_egg_basket_plugin_manager.py", line 150, in test_ignore_broken_plugins_raises_exceptions_by_default
    list(plugin_manager)
AssertionError: ImportError not raised
-------------------- >> begin captured logging << --------------------
envisage.egg_basket_plugin_manager: DEBUG: egg basket plugin manager found plugins <[]>
--------------------- >> end captured logging << ---------------------

======================================================================
FAIL: test_ignore_plugins_matching_a_wildcard_in_the_exclude_list (envisage.tests.test_egg_basket_plugin_manager.EggBasketPluginManagerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/envisage-5.0.0/envisage/tests/test_egg_basket_plugin_manager.py", line 127, in test_ignore_plugins_matching_a_wildcard_in_the_exclude_list
    self._test_start_and_stop(plugin_manager, expected)
  File "/builddir/build/BUILD/envisage-5.0.0/envisage/tests/test_egg_basket_plugin_manager.py", line 221, in _test_start_and_stop
    self.assertEqual(expected, [plugin.id for plugin in plugin_manager])
AssertionError: Lists differ: ['acme.foo'] != []

First list contains 1 additional elements.
First extra element 0:
'acme.foo'

- ['acme.foo']
+ []
-------------------- >> begin captured logging << --------------------
envisage.egg_basket_plugin_manager: DEBUG: egg basket plugin manager found plugins <[]>
--------------------- >> end captured logging << ---------------------

======================================================================
FAIL: test_ignore_plugins_whose_ids_are_in_the_exclude_list (envisage.tests.test_egg_basket_plugin_manager.EggBasketPluginManagerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/envisage-5.0.0/envisage/tests/test_egg_basket_plugin_manager.py", line 110, in test_ignore_plugins_whose_ids_are_in_the_exclude_list
    self._test_start_and_stop(plugin_manager, expected)
  File "/builddir/build/BUILD/envisage-5.0.0/envisage/tests/test_egg_basket_plugin_manager.py", line 221, in _test_start_and_stop
    self.assertEqual(expected, [plugin.id for plugin in plugin_manager])
AssertionError: Lists differ: ['acme.bar'] != []

First list contains 1 additional elements.
First extra element 0:
'acme.bar'

- ['acme.bar']
+ []
-------------------- >> begin captured logging << --------------------
envisage.egg_basket_plugin_manager: DEBUG: egg basket plugin manager found plugins <[]>
--------------------- >> end captured logging << ---------------------

======================================================================
FAIL: test_only_find_plugins_matching_a_wildcard_in_the_include_list (envisage.tests.test_egg_basket_plugin_manager.EggBasketPluginManagerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/envisage-5.0.0/envisage/tests/test_egg_basket_plugin_manager.py", line 93, in test_only_find_plugins_matching_a_wildcard_in_the_include_list
    self._test_start_and_stop(plugin_manager, expected)
  File "/builddir/build/BUILD/envisage-5.0.0/envisage/tests/test_egg_basket_plugin_manager.py", line 221, in _test_start_and_stop
    self.assertEqual(expected, [plugin.id for plugin in plugin_manager])
AssertionError: Lists differ: ['acme.bar', 'acme.baz'] != []

First list contains 2 additional elements.
First extra element 0:
'acme.bar'

- ['acme.bar', 'acme.baz']
+ []
-------------------- >> begin captured logging << --------------------
envisage.egg_basket_plugin_manager: DEBUG: egg basket plugin manager found plugins <[]>
--------------------- >> end captured logging << ---------------------

======================================================================
FAIL: test_only_find_plugins_whose_ids_are_in_the_include_list (envisage.tests.test_egg_basket_plugin_manager.EggBasketPluginManagerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/envisage-5.0.0/envisage/tests/test_egg_basket_plugin_manager.py", line 76, in test_only_find_plugins_whose_ids_are_in_the_include_list
    self._test_start_and_stop(plugin_manager, expected)
  File "/builddir/build/BUILD/envisage-5.0.0/envisage/tests/test_egg_basket_plugin_manager.py", line 221, in _test_start_and_stop
    self.assertEqual(expected, [plugin.id for plugin in plugin_manager])
AssertionError: Lists differ: ['acme.foo', 'acme.bar'] != []

First list contains 2 additional elements.
First extra element 0:
'acme.foo'

- ['acme.foo', 'acme.bar']
+ []
-------------------- >> begin captured logging << --------------------
envisage.egg_basket_plugin_manager: DEBUG: egg basket plugin manager found plugins <[]>
--------------------- >> end captured logging << ---------------------

Above is shortened output, for complete build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01922810-python-envisage/

For all our attempts to build python-envisage with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-envisage/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Orion Poplawski 2021-02-02 04:36:34 UTC
Perennial issue with envisage and new python versions.  Reported upstream.

Comment 2 Ben Cotton 2021-02-09 15:44:57 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 3 Miro Hrončok 2021-06-04 20:15:28 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 4 Miro Hrončok 2021-06-07 22:59:54 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 5 Miro Hrončok 2021-06-08 11:24:49 UTC
*** Bug 1968967 has been marked as a duplicate of this bug. ***

Comment 6 Miro Hrončok 2021-07-26 11:57:11 UTC
Creating the test eggs during build works: https://src.fedoraproject.org/rpms/python-envisage/pull-request/2

Comment 7 Miro Hrončok 2021-08-03 10:44:03 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.