Bug 1923036 - Jenkins templates are displayed in Developer Catalog twice
Summary: Jenkins templates are displayed in Developer Catalog twice
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Jenkins
Version: 4.7
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: 4.7.z
Assignee: Vibhav Bobade
QA Contact: Jitendar Singh
URL:
Whiteboard:
Depends On: 1930570
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-01 10:27 UTC by Vibhav Bobade
Modified: 2021-07-26 17:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1930570 (view as bug list)
Environment:
Last Closed: 2021-07-26 17:35:21 UTC
Target Upstream Version:
pbhattac: needinfo-
jitsingh: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 359 0 None closed [release-4.7] Bug 1923036: Update Jenkins monitored templates names 2021-06-28 04:51:30 UTC
Github openshift jenkins pull 1208 0 None closed Bug 1923036: Fix monitored Jenkins templates display names 2021-06-28 04:51:37 UTC
Red Hat Product Errata RHBA-2021:2762 0 None None None 2021-07-26 17:35:37 UTC

Description Vibhav Bobade 2021-02-01 10:27:51 UTC
Description of problem:
Jenkins templates are displayed in Developer Catalog twice


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Jitendar Singh 2021-02-12 05:18:11 UTC
This is not a blocker.

Comment 4 Jitendar Singh 2021-02-18 09:34:29 UTC
Still see duplicate templates. reducing the priority as its not blocking/breaking any component

Comment 5 Jitendar Singh 2021-02-19 05:06:56 UTC
eparis@redhat.com, - can you remove this from being a blocker as this doesnt block anything.

Comment 6 Pradeepto Bhattacharya 2021-02-19 05:48:07 UTC
@jitsingh@redhat.com  I have removed the blocker tag.

Comment 10 Jitendar Singh 2021-06-28 04:57:11 UTC
@vbobade@redhat.com We still dont have the fix. Can you please look into this.

Comment 12 Gabe Montero 2021-07-06 14:34:56 UTC
I've confirmed this fixed in 4.7.0-0.nightly-2021-07-03-010214 

in fact, the fix was in as early as https://amd64.ocp.releases.ci.openshift.org/releasestream/4.7.0-0.nightly/release/4.7.0-0.nightly-2021-06-24-030912

I've provided the screenshot to Jitendar in slack.  But will attempt to attach here as well.

Jitendar - I'm going to first move this back to modified, to see if ART automation and elliott will put it back in the errata

Hopefully the answer is yes, and then once it goes to ON_QA, we can just mark this as verified and move on.

If we see a delay, I'll reach out to the ART folks to try and clean this up.

Comment 14 Gabe Montero 2021-07-06 14:36:47 UTC
Vibhav fixed this ... assigning to him.

Comment 15 Jitendar Singh 2021-07-07 04:52:15 UTC
VERFIED
==============
Fix present in 4.7.0-0.nightly-2021-07-03-010214

Comment 18 Siddharth Sharma 2021-07-09 21:08:05 UTC
OCP engineering has decided to not ship 4.7.20 due to a blocker. This bug will be shipped as part of next z-stream release 4.7.21 planned on July 27th

Comment 21 errata-xmlrpc 2021-07-26 17:35:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.21 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2762


Note You need to log in before you can comment on or make changes to this bug.