Bug 192306 - Needs to be rebuilt against newer php in core
Needs to be rebuilt against newer php in core
Product: Fedora
Classification: Fedora
Component: php-eaccelerator (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
: 192543 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2006-05-18 16:57 EDT by Chris Weyl
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.1.4_0.9.5-0.2.beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-23 05:24:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Weyl 2006-05-18 16:57:17 EDT
Package needs to be rebuilt for php 5.1.4, now in core.

package: php-eaccelerator - 5.1.2_0.9.3-0.3.fc5.i386 from fedora-extras-5-i386
 unresolved deps:
    php = 0:5.1.2
Comment 1 Matthias Saou 2006-05-23 04:55:51 EDT
*** Bug 192543 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Saou 2006-05-23 05:24:40 EDT
Packages of eaccelerator 0.9.5beta2 (which works much better with PHP 5.1.x)
have now been rebuilt and should appear shortly.
Comment 3 Tim Jackson 2006-05-23 13:40:23 EDT
Does the package really require an exact version of PHP or can it use the new
php-api dep (see bug #183227)? The latter would save you having to rebuild for
each PHP version as long as the interface doesn't change.
Comment 4 Matthias Saou 2006-05-26 10:54:04 EDT
Already done in the new package :-)

# rpm -q --requires php-eaccelerator-5.1.4_0.9.5-0.2.beta2.fc6
config(php-eaccelerator) = 5.1.4_0.9.5-0.2.beta2.fc6
php-api = 20041225
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

The only downside is that because of the version I was using, it's not possible
to remove the PHP version without introducing an epoch... so the "information"
about the PHP version used to build the package is still there :-/

Note You need to log in before you can comment on or make changes to this bug.